Project

General

Profile

Bug #1570

Error in uploading raw data to metacat...

Added by Saurabh Garg almost 15 years ago. Updated almost 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
05/18/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1570

Description

Following error was reported by Johnoel Ancheta <>

i am having some problems uploading to our metacat
server using morpho-1.5.1. it seems i can upload the
metadata but not the raw data. the error log is below.

docid in parseIdFromMessage: user1.54.1
MetacatDataStore: getting file from Metacat
Sending data to: https://localhost:8443/tao/servlet/metacat
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Name: docid => user1.54.1
Name: action => read
Name: qformat => xml
MetacatDataStore: getting file from Metacat
Sending data to: https://localhost:8443/tao/servlet/metacat
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Name: docid => WC97_241.2.1
Name: action => read
Name: qformat => xml
opening WC97_241/2.1 from temp dir - temp:
/home/tombo/johnoel/.morpho/profiles/user1/temp
id:WC97_241.2.1 filelength:4266572
Sending data to: |https://localhost:8443/tao/servlet/metacat|
Sending data file:
/home/tombo/johnoel/.morpho/profiles/user1/data/WC97_241/2.1
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
HTTP Handler class is: sun.net.www.protocol.https.HttpsURLConnectionImpl
Fatal error sending binary data to Metacat: Illegal character(s) in
message header value: multipart/form-data;
boundary=--------ieoau._._+2_8_8.3-dskdfJwSJKl234324jfLdsjfdAuaoei-----^M

java.lang.Exception: Illegal character(s) in message header value:
multipart/form-data;
boundary=--------ieoau._._+2_8_8.3-dskdfJwSJKl234324jfLdsjfdAuaoei-----^M

at edu.ucsb.nceas.morpho.Morpho.sendDataFile(Morpho.java:743)
at
edu.ucsb.nceas.morpho.datastore.MetacatDataStore.newDataFile
(MetacatDataStore.java:610)
at
edu.ucsb.nceas.morpho.datapackage.AbstractDataPackage.handleMetacat
(AbstractDataPackage.java:2734)
at
edu.ucsb.nceas.morpho.datapackage.AbstractDataPackage.serializeData
(AbstractDataPackage.java:2623)
at
edu.ucsb.nceas.morpho.datapackage.EML200DataPackage.upload
(EML200DataPackage.java:267)
at
edu.ucsb.nceas.morpho.datapackage.DataPackagePlugin.upload
(DataPackagePlugin.java:974)
at
edu.ucsb.nceas.morpho.query.LocalToNetworkCommand$1.construct
(LocalToNetworkCommand.java:226)
at
edu.ucsb.nceas.morpho.framework.SwingWorker$2.run(SwingWorker.java:140)
at java.lang.Thread.run(Thread.java:534)
id:user1.55.1 filelength:4266572

Related issues

Is duplicate of Morpho - Bug #1571: Error in uploading raw data to metacat...Resolved2004-05-18

Is duplicate of Morpho - Bug #1572: Error in uploading raw data to metacat...Resolved2004-05-18

Is duplicate of Morpho - Bug #1996: Unable to load into MetacatResolved2005-03-01

History

#1 Updated by Saurabh Garg almost 15 years ago

  • Bug 1572 has been marked as a duplicate of this bug. ***

#2 Updated by Saurabh Garg almost 15 years ago

  • Bug 1571 has been marked as a duplicate of this bug. ***

#3 Updated by Saurabh Garg almost 14 years ago

Johnoel - can you try replacing this

((HttpURLConnection)con).setRequestProperty("Content-Type", ctype + "\r\n");

with

((HttpURLConnection)con).setRequestProperty("Content-Type", ctype);

in morpho/src/edu/ucsb/nceas/morpho/framework/HttpMessage.java and see if that
works for you... thanks.

#4 Updated by Saurabh Garg almost 14 years ago

Removed \r\n for Multipart form as described in the comment above. This should
fix the problem regarding the upload. Matthew tried this out and it had fixed
his problem.

Closing the bug

#5 Updated by Saurabh Garg almost 14 years ago

  • Bug 1996 has been marked as a duplicate of this bug. ***

#6 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 1570

Also available in: Atom PDF