Project

General

Profile

Bug #1601

Metacat will add default value for optional parameter into eml 2 document

Added by Jing Tao over 15 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
06/11/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1601

Description

When user upload a eml2 document into metacat, metacat will automatically add
some default value to optional parmaters even the document doesn't have
paramters orginally. So metacat modified the orginal documents, this is not our
stratege and we need fixed it.

For example, here is a segment of eml document:
<address>
<deliveryPoint>Dept. of Marine Sciences</deliveryPoint>
<deliveryPoint>University of Georgia</deliveryPoint>
<city>Athens</city>
<administrativeArea>Georgia</administrativeArea>
<postalCode>30602-3636</postalCode>
<country>USA</country>
</address>

Metacat will modified to:
<address scope="document">
<deliveryPoint>Dept. of Marine Sciences</deliveryPoint>
<deliveryPoint>University of Georgia</deliveryPoint>
<city>Athens</city>
<administrativeArea>Georgia</administrativeArea>
<postalCode>30602-3636</postalCode>
<country>USA</country>
</address>

It adds "scope="document"" to address element. In eml2 schema scope is an
optional parameter and it has a default value "document". Xerces parser will add
default value "document" to parameter "scope" if "scope" doesn't show in xml
instance.

We need figure out a way to get rid of this unexpected modification to orgin xml
document in metacat.

History

#1 Updated by Saurabh Garg about 13 years ago

We need to checkout the newer versions of Xerces and see if the newer version provides an option to avoid entering of these attributes.

#2 Updated by Jing Tao over 11 years ago

Move to milestone 1.9 release

#3 Updated by Michael Daigle about 11 years ago

In Metacat 1.9, the document is read back from disk, so it will be returned verbatim.

#4 Updated by Michael Daigle about 11 years ago

Still want to fix it for future docs in the db.

#5 Updated by Michael Daigle about 11 years ago

Read problem is solved by retrieving doc from disk. Insert problem defered to 1.9.1

#6 Updated by Matt Jones almost 8 years ago

Marking as complete, because the read problem is fixed based on now reading original from disk. The insert problem isn't a problem, because it is actually good that default values be inserted into the XML for searching purposes. So, all is now working as needed. Closing ticket.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1601

Also available in: Atom PDF