Project

General

Profile

Bug #1805

Force quit of one Morpho window closes other windows

Added by Andrea Andrea over 15 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
12/03/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1805

Description

When force quitting (Ctrl-Alt-Del) the Morpho help, or a data package, other
Morpho windows also close, including any open search results windows, and
sometimes the main Morpho window. It would be nice to have the one window you
want to be closed close, and have these other windows stay open, so as not to
have to re-open Morpho and repeat searches, etc.

History

#1 Updated by Matt Jones over 15 years ago

Force-quitting is not a legitimate user-action under normal circumstances -- it
is only intended to allow someone to terminate an entire application if a fatal
error occurs. So I think it is doing exactly what it is supposed to do --
terminating all morpho processes. If you simply use the close box on the window
it should close without affecting any other parts of Morpho. Why are you using
force-quit?

#2 Updated by Andrea Andrea over 15 years ago

Force quit is necessary when a data package window freezes (which occurs
occassionally), and the close box doesn't respond.

#3 Updated by Matt Jones over 15 years ago

That sounds like a significant problem. Is there a bug detailing the freeze
problem? We need details to find and fix bugs like that. If we can replicate
the freeze problem then we'll definitely prioritize fixing it. But we still
can't do anything about the force-quit feature -- it is part of the OS, not part
of Morpho or any other application.

#4 Updated by Andrea Andrea over 15 years ago

The freeze problem is not reproducible as of yet.

#5 Updated by ben leinfelder almost 10 years ago

no force quit for individual windows - and the freezing is non-specific in this (old) bug report.

#6 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 1805

Also available in: Atom PDF