Project

General

Profile

Bug #1901

Documentation system

Added by Ilkay Altintas almost 15 years ago. Updated about 14 years ago.

Status:
Resolved
Priority:
Immediate
Category:
general
Target version:
Start date:
01/21/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1901

Description

  1. Ilkay: Documentation system (Chad helps from SEEK side)
    • Includes way to serialize docs for atomic and composite actors (and
      directors, and utilities, etc)
      o Possible way to put this documentation as linked annotations right
      on the canvas

Related issues

Is duplicate of Kepler - Bug #1900: Documentation systemResolved01/21/2005

History

#1 Updated by Ilkay Altintas almost 15 years ago

  • Overall user guide (need a scientist to do this, not a devloper; possibly
    hire a student; Ilkay's student; Samantha)
    o How-to manuals chapters for specific computational tasks (patterns
    of use) (for example, how to do iteration in a workflow)
    o Samantha, Rod: Introduction to how you build workflows (tutorial
    style; instant gratification guide)

#2 Updated by Ilkay Altintas almost 15 years ago

  • All developers: Actor specific, automatically-generated actor documentation
    o (quick sentence description, multi-paragraphs, categorization, port
    signatures); use different parts of this for different parts of generated
    documentation * Ilkay: FAQ for users

#3 Updated by Ilkay Altintas almost 15 years ago

  • Bug 1900 has been marked as a duplicate of this bug. ***

#5 Updated by Matt Jones almost 15 years ago

Nice job. I annotated the wiki page with additional comments -- when other
comments are in, could you integrate them into the draft Ilkay?

#6 Updated by Chad Berkley over 14 years ago

At the june 05 kepler meeting, we decided that ilkay would come up with a format
for actor man pages along with doc sections for 3 example workflows (helloworld,
R->plot, and dataset extraction). Ilkay is charged with coming up with the new
man page format and sam and laura are charged with creating the example WF pages.

#7 Updated by Ilkay Altintas about 14 years ago

Done items:
  • Includes way to serialize docs for atomic and composite actors (and
    directors, and utilities, etc)
    o Possible way to put this documentation as linked annotations right
    on the canvas
    THIS WAS DONE USING XSLT. WE STILL NEED TO ADD THIS DOC AS A TIP ON THE ACTOR.
  • Overall user guide (need a scientist to do this, not a devloper; possibly
    hire a student; Ilkay's student; Samantha)
    SAMANTHA AND NANDITA HAS WORKED ON THIS.
    o How-to manuals chapters for specific computational tasks (patterns
    of use) (for example, how to do iteration in a workflow)
    THIS IS AN ACTION ITEM FOR FUTURE.
    o Samantha, Rod: Introduction to how you build workflows (tutorial
    style; instant gratification guide)
    SHOULD BE DONE IN THE MANUAL BY SAMANTHA.

All developers: Actor specific, automatically-generated actor documentation
o (quick sentence description, multi-paragraphs, categorization, port
signatures); use different parts of this for different parts of generated
documentation
HAS TO BE DONE IN THE KAR FILES USING THE NEW FORMAT. WE NEED TO
GENERATE THE FORMAT AS A START AUTOMATICALLY FROM THE ACTOR CODE. * Ilkay: FAQ for users
DONE. Needs to evolve.

--At the june 05 kepler meeting, we decided that ilkay would come up with a format
for actor man pages along with doc sections for 3 example workflows (helloworld,
R->plot, and dataset extraction). Ilkay is charged with coming up with the new
man page format and sam and laura are charged with creating the example WF pages.

WE'LL UPDATE WHAT MATT HAS PUT TOGETHER AND ALSO GENERATE DOC TEMPLATES FOR
3 EXAMPLE WORKFLOWS. Then we'll let Samantha and Laura know to put it documentation.

I'LL CREATE A NEW BUG FOR THE NEW ACTION ITEMS. SO THIS BUG IS CLOSED NOW.

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1901

Also available in: Atom PDF