Project

General

Profile

Bug #215

need query composition module

Added by Matt Jones over 19 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/09/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
215

Description

need a module that can combine the results of multiple query screens into a
single pathquery document for submission to the query execution engine. We
agreed in March that this could be essentially a boolean AND (INTERSECT) among
the different query types (text, taxonomic, spatial, etc), but it needs to be
possible. The user interface for the query component might be a series of
tabbed panes ina dialog, so the entity that creates the dialog might also be the
one that combines the queries.


Related issues

Is duplicate of Morpho - Bug #126: boolean combinations of search panelsResolved09/20/2000

Blocks Morpho - Bug #214: Redesign query pluginResolved04/09/2001

History

#1 Updated by Matt Jones over 19 years ago

  • Bug 120 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones over 19 years ago

  • Bug 126 has been marked as a duplicate of this bug. ***

#3 Updated by Matt Jones over 19 years ago

Done. Queries can now be composed using the API found in the Query class, and
the QueryDialog class is able to combine queries from the multiple query
composition tabs into a single unified pathquery, which can be serialized as XML
and reloaded into the QueryDialog when needed (for revisions, etc). Will need
to add the spatial query tab into this functionality when it is developed.

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 215

Also available in: Atom PDF