Project

General

Profile

Actions

Bug #2171

closed

Add support for missingValueCode in EML parser

Added by Jing Tao over 17 years ago. Updated almost 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
data access
Target version:
Start date:
08/15/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2171

Description

Currently, EML parser doesn't handle missingValueCode. We should replace the
missingValueCode by NULL in the data file.


Related issues

Blocks Kepler - Bug #2240: add support for null values to data passing among portsResolvedChristopher Brooks11/02/2005

Actions
Blocked by Kepler - Bug #2350: Add null token to eml datasourceResolvedJing Tao02/07/2006

Actions
Actions #1

Updated by Matt Jones over 17 years ago

This also depends on being able to handle the NULL values as well, which will be
entered as a separate bug.

Actions #2

Updated by Matt Jones over 17 years ago

Adding dependency to null value handling bug.

Actions #3

Updated by Jing Tao almost 17 years ago

  • Bug 2350 has been marked as a duplicate of this bug. ***
Actions #4

Updated by Jing Tao almost 17 years ago

EML parser now can stored missingValue. According Ptolemy adding NULL Token
connecpt, Kepler will transfer the missing value to NULL Token. The null tokens
now we can handle include int, long, double and string. Since Ptolemy haven't
finailized the NULL token yet, kepler will keep changeing too.

Actions #5

Updated by Jing Tao almost 17 years ago

Christopher added NIL Token in ptolemy and our mssingValue can be expressed as NIL Token. So this bug fixed.

Actions #6

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 2171

Actions

Also available in: Atom PDF