Project

General

Profile

Actions

Bug #218

closed

need query execution module

Added by Matt Jones almost 22 years ago. Updated almost 21 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/09/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
218

Description

Need a query execution module that takes a pathquery document as input and
returns a resultset (in XML format) as output. The same module should be used
for both network and local queries. Initially, this means it will execute an
XPath Query locally, and a metacat query on the net, and merge the results into
one resultset (presumably by accession#), indicating where each result record is
located). Eventually this might turn into a metacat search locally if John's
attempts to port metacat to a local client work out. This is related to the
resultset handling widget that Matt is working on.


Related issues

Is duplicate of Morpho - Bug #76: local and network queries should work the sameResolvedDan Higgins08/20/2000

Actions
Blocked by Morpho - Bug #219: need ResultSet handling UIResolvedMatt Jones04/09/2001

Actions
Actions #1

Updated by Matt Jones almost 22 years ago

  • Bug 76 has been marked as a duplicate of this bug. ***
Actions #2

Updated by Matt Jones over 21 years ago

Finished. The Query class encapsulates the constraints that should be used for
searching, and contains an "execute()" method that will launch either a local
query, a metacat query, or both, and returns a single, integrated ResultSet.
This ResultSet has a reference to the Query embedded within it, so it can be
accessed again later for revision or re-execution.

Actions #3

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 218

Actions

Also available in: Atom PDF