Project

General

Profile

Bug #219

need ResultSet handling UI

Added by Matt Jones about 19 years ago. Updated about 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
04/09/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
219

Description

Need to redesign the resultset handling UI. Should take an XML document
representing the resultset, and create the data stroage mechanism for it. It
should then be able to display the resultset in either a tabbed pane, or a
window. Initially, the "My Data Packages" tab will be populated by a query for
all packages owned by the current user. Being able to rip tabs off as Windows
seems useful. There should be a UI widget for calling up (and refining) query
using the query composition dialog box. Various actions on resultset records
should call the Data Package module to handle opening, viewing, and changing.
Consider whether the resultset columns should be configurable or not (probably).


Related issues

Is duplicate of Morpho - Bug #120: customizable resultset displayResolved09/20/2000

Is duplicate of Morpho - Bug #127: change resultset display to be dataset orientedResolved09/20/2000

Is duplicate of Morpho - Bug #153: 'double click' functionality neededResolved09/26/2000

Is duplicate of Morpho - Bug #167: Search & resultSet ConfigurationResolved10/31/2000

Blocks Morpho - Bug #218: need query execution moduleResolved04/09/2001

Blocked by Morpho - Bug #214: Redesign query pluginResolved04/09/2001

Blocked by Morpho - Bug #90: need data "browse" capabilityResolved08/20/2000

History

#1 Updated by Matt Jones about 19 years ago

  • Bug 127 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones about 19 years ago

  • Bug 120 has been marked as a duplicate of this bug. ***

#3 Updated by Matt Jones about 19 years ago

  • Bug 167 has been marked as a duplicate of this bug. ***

#4 Updated by Matt Jones about 19 years ago

  • Bug 153 has been marked as a duplicate of this bug. ***

#5 Updated by Matt Jones about 19 years ago

Feature implememented using the ResultPanel and ResultFrame classes.
ResultPanel displays a configurable set of columns of metadata about each
dataset returned. ResultFrame is a window that contains a ResultPanel. Still
need to add "Refresh" and "Revise query..." UI widgets to trigger rerunning the
query and opening the query in the QueryDialog, respectively.

#6 Updated by Matt Jones about 19 years ago

Refresh and Revise buttons now work properly. Queries are reloaded into the
query dialog when revise is hit, or simply rerun when refresh is clicked. The
resultpane is complete.

#7 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 219

Also available in: Atom PDF