Project

General

Profile

Bug #2200

Morpho editor creates unwanted node (spatialVector)

Added by Veronique Connolly over 14 years ago. Updated almost 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
09/20/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2200

Description

I had a data package containing a data table with two attributes, Column 1 and
Column 2. I opened morpho's editor, clicked on "Show All", and expanded
dataTable/CHOICE/SEQUENCE/attributeList/CHOICE/attribute-Column
1/CHOICE/SEQUENCE. I right-clicked on the missingValueCode node and selected
"Copy Node & Children". I then right-clicked on "attribute-Column 2" and
selected "Paste as Sibling to Selected Node". [I actually wanted to paste the
missingValueCode node under attribute-Column 2/CHOICE/SEQUENCE/ (where this node
should be in theory), but the editor didn't give me this option.] I entered -999
in the missingValueCode field and clicked on "Trim". I expanded dataset/CHOICE
and noticed that spatialVector (with its box checked in) appeared under
dataTable, although I had not created this node. When I clicked on OK to close
the editor, I got a window filling my screen with a list of 59 nodes under
eml/dataset/CHOICE/datatable/CHOICE/SEQUENCE/physical/CHOICE/SEQUENCE/dataFormat/CHOICE/externallyDefinedFormat/citation/CHOICE/SEQUENCE/CHOICE/conferenceProceedings/
and
eml/dataset/CHOICE/datatable/CHOICE/SEQUENCE/physical/CHOICE/SEQUENCE/dataFormat/CHOICE/externallyDefinedFormat/citation/CHOICE/SEQUENCE/CHOICE/personalCommunication.
The only way to get out of there was to press "Esc".


Related issues

Is duplicate of Morpho - Bug #2208: tree editor checks spatialVector after editing any field in data packages containing data TablesResolved09/28/2005

History

#1 Updated by Veronique Connolly over 14 years ago

In a different data package, the taxonomicCoverage node was inserted by the
editor (this node was not present in the initial dp).

#2 Updated by Margaret O'Brien over 14 years ago

A similar experience on this file:
http://sbcdata.lternet.edu/catalog/metacat?action=read&qformat=xml&docid=knb-lter-sbc.13.3
Morpho added a node (dateTimeDomain), labeled it required in the tree editor,
then sent an error mesage because there was no content. The eml201 schema says
dateTimeDomain is optional.
- mob

#3 Updated by Will Tyburczy over 14 years ago

  • Bug 2208 has been marked as a duplicate of this bug. ***

#4 Updated by P. Anderson over 14 years ago

It's difficult to distinguish exactly what triggers the unintended behavior. I
did notice that spatialVector was checked after a copy and paste of
missingValueCode, but then I tried copy-and-pasting a whole attribute and
spatialVector was NOT checked.

#5 Updated by P. Anderson over 14 years ago

Will pointed out that changing any text field in the data table will check the
spatialVector field's checkbox in the morpho editor, but only if the
spatialVector is already present (which will happen if you click "show all").

This detail may be important because it illustrates that the spatialVector node
is not being added when a field's value is change. The spatialVector's state is
changed only if the spatialVector node is already present.

#6 Updated by Jing Tao almost 14 years ago

The reason caused the bug was setAllNodesAsSelected method was called duplicately. When removed one, it works.

#7 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 2200

Also available in: Atom PDF