Project

General

Profile

Bug #2203

Morpho editor gives validation problem message when you don't trim

Added by Veronique Connolly about 15 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
09/20/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2203

Description

When you open morpho editor, click on "show all", make a change in one of the
nodes that appeared, and then click on OK (to close the editor) without clicking
on "Trim", you get this message:

Validation Problem!
The saved document is not valid EML2 for some reason. You can save it locally
and fix the problem later, but you will be unable to submit it to the network
storage system.
Do you want to Continue Exiting the Editor?

History

#1 Updated by Margaret O'Brien about 15 years ago

This is morpho version 1.6rc1
Error message from morpho's tree editor varied depending on how I reached the
tree editor.
When morpho can't edit using one of the dialog boxes, it defaults to the tree
editor. When it finds invalid eml, the error message is something like "this
file is not valid EML for some reason and cant be saved to the network". There
is no indication of what part of the doc is invalid, so this message is not much
use.
But when I reach the tree editor by choosing "Documentation->Add/edit
documentation", there is a much friendlier error message for invalid EML, which
gives you the paths that are missing content. Can this very useful error message
replace the one mentioned above?
-mob

#2 Updated by Saurabh Garg about 15 years ago

There is not enough information in this bug to reproduce it. And this bug might
be dependent on bug # 2200.

Hence I think it would be a good idea to ask Veronique and Margaret to test
Morpho once 2200 is fixed. If they cant reproduce the bug, then we can close
it. Otherwise, they can enter a more detailed bug report about how to reproduce
the problem.

#3 Updated by P. Anderson about 15 years ago

One of the problems is fixed. I pointed the parser/validator at the right xsd
based on eml version.

Bug # 2200 is the other problem which could be leading to this error message.

#4 Updated by Jing Tao over 14 years ago

After fixing bug 2200, this bug was fixed too.

#5 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2203

Also available in: Atom PDF