Project

General

Profile

Bug #2285

Morpho creates a duplicate dp that has an existing docid

Added by Veronique Connolly almost 15 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
11/22/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2285

Description

I saved a dp as a duplicate of connolly.258.5. The new dp was named
connolly.261.1. The thing is that ecogrid://knb/connolly.261.1 was a table I had
in connolly.258.5, so when the duplicate was created, it overwrote that table.

I don't know if this has anything to do with the problem, but the original
connolly.261.1 (the table) was not created on the computer I used when creating
the duplicate dp (it was copied into
.morpho\profiles\<profilename>\data\connolly along with connolly.258.5).


Related issues

Blocks Morpho - Bug #2360: Document Identifier Conflict ResolutionResolved02/16/2006

History

#1 Updated by Callie Bowdish over 12 years ago

Please note the information managers in South Africa are hesitant to upgrade to the latest version of Morpho because it does not notify users when there is a duplicate version of the data package or data table on Metacat. Here is an email I received today for Nikki, working with SAOEN.

  1. I have a data package entitled Andover Vegetation Data nikkis34.15 which is saved locally
  2. I set my preferences to link to Judiths computer
  3. Then I saved package nikkis 34.15 to the network. No little box appears in the corner saying network and it doesn’t appear online
  4. I then called Judith who suggested to search for the package and then right click on it and press synchonise
  5. When I press that it says ’ there is a data conflict has been found in one or more of the identifiers. If you proceed th identifier for this package will be changed, are you sure you want to proceed’

Here is an example of a profile file


The personal profile document title bowdish.xml at /Users/Callie/.morpho/profiles/bowdish/bowdish.xml conatins the information that sets the last id for Morpho. Note the last id information in this profile file.


<profile> <firstname>Callie</firstname>
<lastname>Bowdish</lastname>
<username>bowdish</username>
<datadir>data</datadir>
<cachedir>cache</cachedir>
<tempdir>temp</tempdir>
<queriesdir>queries</queriesdir>
<searchmetacat>true</searchmetacat>
<searchlocal>false</searchlocal>
<casesensitive>false</casesensitive>
<includesynonyms>false</includesynonyms>
<scope>bowdish</scope>
<lastId>903</lastId>
<separator>.</separator>
<profilename>bowdish</profilename>
<organization>NCEAS</organization>
<dn>uid=bowdish,o=NCEAS,dc=ecoinformatics,dc=org</dn>
</profile>

The problem is that the same profile file can sit on another computer AND have the same scope with a different last id number. Also if Metacat creates an id that includes the login name (part of the scope) that is not "in sync" with a Morpho profile there can be update, insert problems.

I think we saw this with the uploading of the data package on the SAEON test site. (http://dev.nceas.ucsb.edu/knb/style/skins/saeon/) Someone logs in with a their login account associated with the profile on Morpho and uploads a package using the metacat skin. If that package is saved with their profile name (Data Package Identifer prefix) there could be a problem. Because if they use the same profile on a local machine with Morpho it does not know what the last id for a data package was on metacat and could create the same data package id. Then when they want to save it to the network the network will not let them insert because it already exists. It may let them update but they would be updating the wrong data package.

On the NCEAS skin every one who saves a document using the skin has the profile name of nceas even though it is owned by a personal profile. Bowdish can login and save something using the form but when it is saved it is nceas.900.4 and owned by bowdish. That helps prevent problems with last id's. No one uses nceas for their personal profile.

#2 Updated by ben leinfelder almost 11 years ago

now morpho will now check with the metacat server for the last docid used for the current scope - not just the local one on the computer.
This is likely not an issue these days given the more robust docid management and conflict resolution

#3 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 2285

Also available in: Atom PDF