Project

General

Profile

Bug #2502

Should be able to enter missingValueCode elements to dp

Added by Will Tyburczy almost 13 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
07/27/2006
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2502

Description

Missing value codes for attributes are something that most researchers are going to want to be able to enter. We need to support access for this element of EML in Morpho. There are two parts to this:

1) Make the "Show All" feature in the tree editor fully expand the missingValueCode element so the users can enter the codeValue and codeExplanation there

2) Add a feature to the New Data Table Wizard that allows users to enter missing value codes for each attribute.


Related issues

Is duplicate of Morpho - Bug #3550: no way to enter a missingValueCodeResolved10/22/2008

History

#1 Updated by Callie Bowdish over 11 years ago

I think we need to have a recommended practice for dealing with missing values in data sets. Currently the missingValueCode requires hand editing (Morpho can not work with missingValueCode). The question is how important is it to note that there are empty values in a unit of measurement. Because of the extra work involved I am tempted to just not include information regarding empty values in the table attributes. My impression is that most users are able to deal with empty values.

#2 Updated by Jing Tao almost 10 years ago

  • Bug 3550 has been marked as a duplicate of this bug. ***

#3 Updated by ben leinfelder over 9 years ago

The fields are in the current wizard page - but they are not made visible.
We need more room on the page.
Make the frame bigger? (it's 600x800)

#4 Updated by Margaret O'Brien over 9 years ago

a bigger morpho window is a great idea in general. Would this help display the buttons that get chopped off on Macs? (can't find the bug number for that one)
Resizeable is even better.

#5 Updated by ben leinfelder over 8 years ago

Made a single missing value code/explanation field visible and editable. This should be expanded to allow multiple code/explanation pairs as needed. I think one of our "CustomList" widgets would be a fine way to edit these pairs.

#6 Updated by ben leinfelder over 8 years ago

now using a list to add/edit multiple missing value codes for an attribute.

#7 Updated by ben leinfelder over 8 years ago

putting in rough time spent

#8 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 2502

Also available in: Atom PDF