Project

General

Profile

Bug #3121

Morpho dropdown choice for affilicated organization is different on mac, windows, and ubuntu

Added by Callie Bowdish over 12 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
02/01/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3121

Description

The drop down choice for creating a New Profile on Morpho is not consistent with the different Operating systems. Windows had duplicate Organization choices and the Mac and Ubuntu version is missing the choice for OSUSB and some of the sanparks organizations. We need to make them all match and test that they offer the choices needed.


Related issues

Blocks Metacat - Bug #3104: provide accessor for organization lists for clients to build login widgetsNew01/25/2008

History

#1 Updated by Matt Jones over 12 years ago

This is very odd. I don't see how this might happen, unless the different OS releases were built with different versions of the source tree, which would be a bad thing. If the java platform differences are causing this then we need to figure out why and what we can do to fix it.

#2 Updated by ben leinfelder over 12 years ago

the config.xml file that is used to store the list of organizations is housed in the user's .morpho/ folder.
it appears that to get the latest values, you need to delete the existing ~/.morpho/config.xml file.
My hunch is that it is not the OS per se, but rather the different machines having different 'versions' of the config file.

#3 Updated by Shaun Walbridge over 12 years ago

#3104 has the long term solution for this I'm guessing. Morpho clients could poll Metacat for a current list, and refresh the <organization> values stored in config.xml

#4 Updated by Callie Bowdish over 12 years ago

It looks like this problem is caused by testing different versions of the same release number of Morpho. For instance someone makes a change to Morpho on CVS but it is not part of a new release yet. I download the CVS for Morpho and check the changes and then delete that CVS version of Morpho. When I go back to the release that we have offered to the public the config.xml file may have problems because it is edited by opening the CVS version of Morpho.

I closed Morpho then went to the config.xml file in the .morpho directory and deleted it. Then when I opened the production version of Morpho the view of the drop down choices for the organizations looked correct.

I had tested some minor Morpho changes on all three Operating Systems and all three Operating Systems seemed to have had their config.xml file changed in a way the made the drop down list be incorrect when I went back to use the production version.

#5 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 3121

Also available in: Atom PDF