Project

General

Profile

Bug #3182

check for consistent licensing text in all source files

Added by Matt Jones about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Immediate
Category:
general
Target version:
Start date:
03/24/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3182

Description

Kepler is licensed under the BSD. We need to check that all code is properly licensed this way throughout the release, including all source files. Fix any licensing problems that might arise.

We also need to be sure any included software included in the release can be redistributed under the terms of their license, and that we follow those license terms.


Related issues

Blocked by Kepler - Bug #2318: Copyrights and licenses of subpackages need to be handledResolved12/13/2005

History

#1 Updated by Christopher Brooks about 11 years ago

Should this be combined with "Copyrights of subpackages need to be handled"
http://bugzilla.ecoinformatics.org/show_bug.cgi?id=2318

See that bug for a info about the Ptolemy copyright system and FOSSOLOGY.
I tried to install FOSSOLOGY, but it requires many packages to get working . . .

#2 Updated by Matt Jones about 11 years ago

No, I think this is a separate item from the copyright check, even though we might do them simultaneously with a single pass -- so lets leave them as two bugs.

I also checked into FOSSology -- looks interesting but the overhead to install it looks prohibitive, plus it really seems to be focused on the .deb/.rpm system for importing packages and finding package dependencies. As we don't use that (yet) then we might get less out of it.

#3 Updated by Chad Berkley about 11 years ago

I was given permission by John Harris on 4/9/08 to change the license in the code owned by Numeric Solutions. I changed all of the numeric solutions source files and added the following license:

/* * * Copyright (C) 2001 Numeric Solutions. All Rights Reserved. * * Permission is hereby granted, without written agreement and without license * or royalty fees, to use, copy, modify, and distribute this software and its * documentation for any purpose, provided that the above copyright notice * appears in all copies of this software. * * Contact information: Numeric Solutions , or: * * http://www.numericsolutions.com *
*/

#4 Updated by Timothy McPhillips about 11 years ago

Most of the remaining issues are listed under bug #2318 now (as well as bug #3196).

  • This bug has been marked as a duplicate of bug 2318 ***

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3182

Also available in: Atom PDF