Project

General

Profile

Bug #3184

right-click context menu in RExpression actor

Added by Kevin Drury over 11 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
actors
Target version:
Start date:
03/25/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3184

Description

One thing that would make Kepler a more friendly environment for developing analyses would be the ability to highlight an experimental block of code, right-click to reveal a context menu and choose "comment" or "uncomment", then re-run the script. This would work with both the pc and the mac (with a 2-button mouse). A mac w/out mouse uses Alt-click I believe. The comment character in R is "#".


Related issues

Blocks Kepler - Bug #3944: External script editorsNew04/06/2009

History

#1 Updated by ben leinfelder over 11 years ago

the best solution for adding a feature like code commenting would be to use an external editor.
there's apparently a way to hook into emacs by adding a special java argument on the Kepler start up, but I've note tried this yet. It would be very nice if it were "easier" to just select from a list of possible editors installed on any given system.

I think it's unlikely that we'll be adding the comment code feature to the R actor in that it uses ptolemy base classes and the editor is used for all sorts of text editing - not just R.

#2 Updated by ben leinfelder over 10 years ago

closing this in favor of the more general bug (3944)

  • This bug has been marked as a duplicate of bug 3944 ***

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3184

Also available in: Atom PDF