Project

General

Profile

Bug #3191

Merge TextEditor changes with ptII source

Added by ben leinfelder about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
actors
Target version:
Start date:
03/28/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3191

Description

These changes from src/exp in Kepler should be included in the ptII tree:
src/exp/ptolemy/gui
Query.java
UndoListener.java
src/exp/ptolemy/actor/gui
TextEditorTableau.java
TextEditor.java

Christopher Brooks is aware of these changes. See his email below:
-----
These changes sound reasonable to me for the ptII devel trunk.

There is a similar bug that came out of discussions with Ian:
"Editing Python Scripts is difficult"
https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=138

There is this larger question though: We could spend effort on trying
to make a good editor out of TextEditor, or we could solve this
problem in other ways.
I see several possibilities:
1) Enhance TextEditor et al.
- This is not much effort, but developing a full editor is real work.
Edward and I did this with Tycho using Tcl/Tk. The problem is
that people want more and more features (syntax highlighting,
syntax checking, jump from stack trace)

2) Find something better and add it to the ptII tree
- More work, but we end up with something that is probably so so.

3) Provide an interface to an arbitrary editor (Netbeans, Eclipse, Emacs)
- The interface to Emacs sort of works
- I'm not sure if this is possible for Netbeans and Eclipse
4) Interface to something like Netbeans or Eclipse
- This is lots of work, and ties us to one program. However, it
seems like an eventual goal.

Anyway, enhancing TextEditor seems reasonable.

There are also issues concerning modal dialogs. Personally, I really
don't like the modal dialog we use for editing parameters. It makes
it impossible to compare parameters between two actors. However,
because of various reasons surrounding parameter evaluation, we have
modal dialogs. It sounds like we are talking about leaving the Python
code open as a non-modal window? My concern here is that this might
cause other problems. I'm not sure about this though.

Anyway, I say go for checking the changes in. These changes will
probably not appear in the ptII rel-7-0-beta-2 branch. I'm only
folding bug fixes into the rel-7-0-beta-2 branch. This is a rather
nice enhancment, not a bug in current functionality. That said, we
could start a ptII branch for these and other enhancements that would
be used as for the Kepler 1.0 release.

_Christopher
--------


Related issues

Blocked by Kepler - Bug #3185: Ctrl-z does not "undo" in RExpression actorResolved03/25/2008

Blocked by Kepler - Bug #3186: commit RExpression code changes, but leave actor openResolved03/25/2008

Blocked by Kepler - Bug #3187: RExpression actor does not share focusIn Progress03/25/2008

History

#1 Updated by Christopher Brooks about 11 years ago

Ok, I updated Query, UndoListener and TextEditor in the ptII tree and
removed these files from kepler/src/exp/ptolemy.
I did not update TextEditorTableau, see http://bugzilla.ecoinformatics.org/show_bug.cgi?id=3187

I think this bug can probably be closed pending verification that the
changes work.

#2 Updated by ben leinfelder about 11 years ago

closing this bug - I'm happy with the undo/redo. (thanks, cxh)

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3191

Also available in: Atom PDF