Project

General

Profile

Bug #340

need degree/minute/second converter for bounding box entry

Added by Matt Jones about 19 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
11/29/2001
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
340

Description

Degrees in eml are expressed exclusively as decimal degrees, but many scienties
have degrees:minutes:seconds. Need to have an easy to use converter that will
automatically convert d:m:s data to decimal degrees when entering metadata,
possibly automatically. Not sure where this would be incorporated, as it needs
to work on all of the wizards and the xml editor.


Related issues

Is duplicate of Morpho - Bug #672: lat/lon validation and conversionResolved11/08/2002

History

#1 Updated by Matt Jones about 18 years ago

In the current scheme, this could probably be implemented as a custom widget for
the bounding box fields that does conversion and validation. Validation needs to
be done before hte user saves, and be sure to at least notify them if the format
they use is incorrect for EML.

#2 Updated by Matt Jones about 18 years ago

  • Bug 672 has been marked as a duplicate of this bug. ***

#3 Updated by Dan Higgins about 17 years ago

The new geographicCoverage wizard screen incorporates edit boxes that allow
either fractional degrees or deg/min/sec input

#4 Updated by Redmine Admin almost 8 years ago

Original Bugzilla ID was 340

Also available in: Atom PDF