Project

General

Profile

Bug #3738

File -> Save As menu item is missing

Added by Derik Barseghian over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
01/09/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3738

Description

File -> Save As menu item is missing.

History

#1 Updated by Derik Barseghian over 10 years ago

I suspect this may be related to the build system, David do you see this problem too? I see it both on my linux cmd line build, and my mac eclipse build.

#2 Updated by David Welker over 10 years ago

This bug has nothing to do with the build system. The Save As menu item is still available in Kepler 1.0.

#3 Updated by Christopher Brooks over 10 years ago

Edited
kepler/common/configs/ptolemy/configs/kepler/uiMenuMappings_en_US.properties

The change was:
145c145
< File->Save\ ~As...=File->SaveAs
---

File->Save\ ~As...=File->Save\ As

Interestingly, Kepler-1.0 shipped with out the space:
< File->Save\ ~As...=File->SaveAs
but SaveAs still worked. This indicates that a bug was fixed elsewhere?

#4 Updated by David Welker over 10 years ago

This fix did not work for me. I updated the common module to get this update by Christopher Brooks and opened Kepler and the Save As menu was still missing. This might be related to another bug (which I am about to enter) where the kars do not load properly the first time you try to run Kepler from the trunk (Hereinafter "K-trunk"). It seems that the configuration mechanism between 1.0 and trunk has been modified to some degree by someone. One new class I have noticed is KeplerMenuHandler, which is not in 1.0. Perhaps the absence of the "Save As" menu is related to this class... (I don't know if that is true or not.)

I tried running Kepler twice after typing "ant clean-cache" to verify that this is not a caching problem.

#5 Updated by Christopher Brooks over 10 years ago

Interesting that it does not work for you. I'm on a Mac, running Java 1.5.0_16.
I'm running Kepler from the command line using "ant run".

To replicate this, I did:

mkdir kepler
cd kepler
svn co https://code.kepler-project.org/code/kepler/trunk/modules/build-area
cd build-area
ant change-to -Dsuite=vanilla-trunk
ant run

I can make the Save As menu appear and disappear by changing
kepler/common/configs/ptolemy/configs/kepler/uiMenuMappings_en_US.properties

I did a similar test under Windows 2000 Server with Java 1.5.0_17 using
the steps above and was able to make the Save As menu appear and disappear.

Can you give the steps above a try in a separate directory, perhaps on another
machine? This would be interesting to track down, as it is likely to affect
other people as well.

Can someone else try the steps above and see if they get the Save As menu?

It is a mystery as to what changed and caused the initial missing menu choice.
I suspect a bug was fixed after Kepler-1.0, perhaps in the KeplerMenuHandler
class? KeplerMenuHandler was introduced by Chad. The version control log
messages indicate that it is part of the much needed effort to get rid of the
code that duplicates Ptolemy code.

#6 Updated by David Welker over 10 years ago

Interesting.

It actually works with a fresh checkout. I must have modified something else (it was not the uiMenuMappings_en_US.properties file) that was not being updated (precisely because I modified it). Anyway, I am closing this bug because the problem was with my local working copy.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3738

Also available in: Atom PDF