Project

General

Profile

Bug #3978

when adding people from another dataset, check to see that ids are unique

Added by Margaret O'Brien about 10 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
04/13/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3978

Description

a user used the feature to add a creator from a person in another dataset, The incoming responsibleParty had an ID attached. The user did this twice using the first person as the template for the second (since the address was the same). So now, both creators have the same ID in the EML. Morpho should check these IDs.


Related issues

Is duplicate of Morpho - Bug #4253: ids for role confict when the person was imported from another packageResolved07/16/2009

History

#2 Updated by ben leinfelder over 8 years ago

Finally fixed this, though it was motivated not by reading the bug report, but by Jim's work with the jellyfish group!

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3978

Also available in: Atom PDF