Project

General

Profile

Bug #4038

The first time ant change-to is run, it prints a stack trace

Added by Christopher Brooks over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
04/30/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4038

Description

The first time I run ant change-to under Windows, I get:

change-to:
[change-to] java.io.FileNotFoundException: c:\tmp\cxh\src\kepler\build-area\modules.txt (The system cannot fin
d the file specified)
[change-to] at java.io.FileInputStream.open(Native Method)
[change-to] at java.io.FileInputStream.<init>(FileInputStream.java:106)
[change-to] at java.io.FileReader.<init>(FileReader.java:55)
[change-to] at org.kepler.build.modules.ModulesTxt.readHelper(ModulesTxt.java:68)
[change-to] at org.kepler.build.modules.ModulesTxt.read(ModulesTxt.java:57)
[change-to] at org.kepler.build.modules.ModulesTxt.init(ModulesTxt.java:23)
[change-to] at org.kepler.build.modules.ModulesTask.init(ModulesTask.java:59)
[change-to] at org.apache.tools.ant.ComponentHelper.createComponent(ComponentHelper.java:223)
[change-to] at org.apache.tools.ant.UnknownElement.makeObject(UnknownElement.java:414)
[change-to] at org.apache.tools.ant.UnknownElement.maybeConfigure(UnknownElement.java:160)
[change-to] at org.apache.tools.ant.Task.perform(Task.java:347)
[change-to] at org.apache.tools.ant.Target.execute(Target.java:357)
[change-to] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[change-to] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[change-to] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[change-to] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[change-to] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[change-to] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[change-to] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[change-to] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[change-to] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[change-to] Copying 1 file to c:\tmp\cxh\src\kepler\build-area
[change-to] Retrieving modules....

The change-to command completes, but this looks bad and could be confusing.

To replicate:
1. Check out a new tree
2. ant change-to -Dsuite=kepler

History

#1 Updated by Chad Berkley over 10 years ago

I'm also seeing this behavior. It looks like it's trying to read the modules.txt file before it gets checked out.

#2 Updated by Christopher Brooks over 10 years ago

This is fixed, I can no longer reproduce it.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4038

Also available in: Atom PDF