Project

General

Profile

Bug #4592

ROML lost when saving KAR a second time

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
reporting
Target version:
Start date:
12/01/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4592

Description

Create a workflow and report. File->Save Archive. The KAR should contain the ROML. File->Save Archive again, overwriting the original file. I sometimes get this error on the console:

ERROR (org.kepler.kar.handlers.ReportLayoutKAREntryHandler:saveReportLayout:292) Could not set LSID for ReportLayout: null

When it happens, the KAR loses the report layout.


Related issues

Is duplicate of Kepler - Bug #4593: ROML lost when saving workflow with a composite actor to KAR after saving XML after saving to KARResolved12/01/2009

History

#1 Updated by Oliver Soong over 9 years ago

Overwriting turns out not to be necessary. Simply File->Save Archive again.

#2 Updated by Oliver Soong over 9 years ago

  • Bug 4593 has been marked as a duplicate of this bug. ***

#3 Updated by Oliver Soong over 9 years ago

The error occurs on the second File->Save Archive as long as the KAR is not closed and re-opened between.

New workflow, File->Save Archive, File->Save Archive: error
Saved KAR, File->Save Archive: no error
Saved KAR, File->Save Archive, File->Save Archive: error
Saved KAR, File->Save Archive, close & re-open, File->Save Archive: no error
Saved KAR, File->Save Archive, close & re-open, File->Save Archive, File->Save Archive: error

The workaround is to close and re-open the KAR after saving archives. Saving XML doesn't seem to matter.

#4 Updated by Oliver Soong over 9 years ago

The workaround I suggested sometimes seems to trigger bug 4571, so it might be safest to restart Kepler after saving the archive.

#5 Updated by ben leinfelder over 9 years ago

Because the model was being closed and reopened, we trashed the layout on the close (which happened after the "new" freshly saved KAR was opened) so the layout was not actually available for the second save.
Now we will not destroy (in memory) the report layout for a workflow that is still open (in another kepler window).

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4592

Also available in: Atom PDF