Project

General

Profile

Bug #4593

ROML lost when saving workflow with a composite actor to KAR after saving XML after saving to KAR

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
reporting
Target version:
Start date:
12/01/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4593

Description

I haven't isolated exactly what the trigger is, but I think this is the bug I've been trying to track down for a couple of weeks now.

1. Create a workflow with 1 SDF and 1 Composite. In the composite, put 1 RExpression and 1Display hooked to RExpression.graphicsFileName.
2. Add a report (Composite.RExpression.graphicsFileName).
3. File->Save Archive. This KAR should have the ROML.
4. File->Save, then close the XML workflow window.
5. File->Save Archive (do not overwrite). This new KAR should not have the ROML. The console should display:
ERROR (org.kepler.kar.handlers.ReportLayoutKAREntryHandler:saveReportLayout:292) Could not set LSID for ReportLayout: null


Related issues

Has duplicate Kepler - Bug #4592: ROML lost when saving KAR a second timeResolved12/01/2009

History

#1 Updated by Oliver Soong over 9 years ago

I think the trigger here is the second Save Archive, and this now seems to be a duplicate of the (newly modified) bug 4592.

  • This bug has been marked as a duplicate of bug 4592 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4593

Also available in: Atom PDF