Project

General

Profile

Bug #4620

Add handler for externally saving/opening an attached data object

Added by Jim Regetz over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
12/10/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4620

Description

Imagine someone wants to quickly inspect the contents of a binary data file attached to a data package. Currently, the only way to do so is to export the entire DP, then drill down through cryptically named directories in the exported directory tree to manually locate and open the file. There should be a more straightforward way within Morpho to externally save or open a specific attached data object.

For the user, this should behave much like handling an email attachment: e.g., provide some sort of GUI element (button or menu option) that triggers a pop-up dialog presenting the option of saving the data object to disk or opening it with some other application. Note that the Metacat web registry already provides this functionality by presenting a "Download File" link for each attached entity in the DP, and allowing the web browser to handle the rest.

Ideally this functionality would apply not just to data tables, but also to other entity types (especially otherEntity).

Note: The button or menu text should probably be more along the lines of "export data" rather than "open data", otherwise users may be misled into thinking that editing/saving the object in the external application will actually save it within the DP.


Related issues

Is duplicate of Morpho - Bug #1786: Need ability to download data files through morphoResolved11/19/2004

History

#2 Updated by ben leinfelder about 9 years ago

There's now an "Export..." button available when the data cannot be displayed (binary/unknown otherEntity). Text files are still just displayed.
It's probably a good idea to make this feature available from the Data menu so that even text/dataTable files can be exported individually.

#3 Updated by ben leinfelder about 9 years ago

added data menu item:
Data->Export Data...
that is accessible for any entity.

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4620

Also available in: Atom PDF