Project

General

Profile

Bug #4848

only first change to Customize Documentation shown in Documentation=>Display

Added by Derik Barseghian over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
documentation
Target version:
Start date:
02/25/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4848

Description

If I right-click Documentation=>Customize Documentation on an actor, I can change the documentation, and Documentation=>Display will reflect the change. However any subsequent change will not show up in Display (even though the subsequent changes are maintained in the Customize window).


Related issues

Blocked by Kepler - Bug #4072: Rework Section 3Resolved05/18/2009

History

#1 Updated by Derik Barseghian over 9 years ago

The problem is with calling Show Documentation (which calls GetDocumentationAction) twice.

On the first call to GetDocumentationAction, there are 0 docAttributes on the NamedObj, and so the KeplerDocumentationAttribute on the NamedObj is used. KeplerDocumentationAttribute.getDocAttribute is called, which creates a docAttribute. So on the second call to Show Documentation, there's a docAttribute, and since we're just using the default vergil context menu and the docPreference is 0 (which means ptolemy...1 is for kepler), the KeplerDocumentationAttribute is not used.

One idea is to instead use the ShowDocumentationAction ("View Documentation" from the library area), which sets the kepler docPreference. Unfortunately this action can't just be called, it expects certain member variables be set first. I'm looking into adapting this class...

#2 Updated by Derik Barseghian over 9 years ago

fixed for workflows and actors in r23238.

#3 Updated by Derik Barseghian over 9 years ago

I've filed a bug and an ER against vergil re: an NPE on Get Documentation on actor ports, and Customize Documentation not showing existing docs on an actor in vergil:

https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=327
https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=328

Even if these are fixed, Kepler may have the same problem that I describe above for actors and workflows, and likely the fix will be the same or similar.

#4 Updated by Derik Barseghian over 9 years ago

fixed also for Directors in r23268 (trunk) and r23269 (2.0)

#5 Updated by Christopher Brooks over 9 years ago

This bug:
Get Documentation on actor ports can give an NPE
https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=327
has been fixed and verified in Kepler trunk and 2.0.
It should be checked in the Kepler release.

This rfe:
Customize Documentation on actor with documentation gives dialog with blank fields
https://chess.eecs.berkeley.edu/bugzilla/show_bug.cgi?id=328
will not be done in time for Kepler-2.0.0.

Could this bug (4072) be closed?

#6 Updated by Derik Barseghian over 9 years ago

Thanks Christopher. I updated kepler trunk to use ptolemy r57481 and made the required change to uiContextMenuMappings in r23329 so that repeated customizations to the documentation are shown with Documentation=>Display by using the ShowDocumentationAction action instead of Get Documentation for ports and attributes (required for this to work in Kepler).

I think you made a typo in your comment and intended to refer to this bug (4848), which yes, I'm going to close now. If you really did mean 4072, that one needs to stay open until I get Remove Documentation working (bug#4852).

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4848

Also available in: Atom PDF