Project

General

Profile

Bug #4858

Open Actor on non-composite actors no longer works

Added by Derik Barseghian over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
03/01/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4858

Description

Drag a Display to canvas, right-click Open Actor and you'll get an Error popup:
Cannot find a tableau or the source code for .Unnamed1.Display.

EclipseKeplerClasspathDialog.png (115 KB) EclipseKeplerClasspathDialog.png Christopher Brooks, 03/02/2010 02:32 PM

History

#1 Updated by Christopher Brooks over 9 years ago

Hmm, this works for me in the Kepler devel tree and the Ptolemy tree.
I'm running from the

#2 Updated by Christopher Brooks over 9 years ago

[Sorry, committed before being done].

I can't reproduce this. I'm running the Kepler devel tree
from the ptII head.

1. ant update; ant clean; ant run
2. Go to the left hand actor library pane, type Display into
the search window
3. Find the Display actor under
Search Results
Components
Data Output
Workflow Output
Textual Display

4. Drag the Display into the canvas
5. Control-Click (I'm on the Mac)
Select "Open Actor"

The source appears.

The source also appears if I do Command-L.

Vergil running under Ptolemy also works fine.

So, there must be something else up?

The error message "Cannot find a tableau or the source code"
comes from ptolemy.actor.gui.Configuration

#3 Updated by Derik Barseghian over 9 years ago

Hey Christopher,
Thanks, it works for me on trunk too, I should've tried that and also specified: this is currently a problem for me on the 2.0 branch. I just tried a clean-cache and rm -rf ~/KeplerData and restarting, but I still get the error on the branch.

#4 Updated by Chad Berkley over 9 years ago

I just tried this with the 2.0 branch and it worked for me. Have you tried a fresh checkout, derik? Also, are you using eclipse or ant? I tried with ant and it works fine.

#5 Updated by Chad Berkley over 9 years ago

Oh, I should also note that I updated the context menu configuration last week to match up with some new ptolemy menu configurations. Make sure your copy of uiContextMenuMappings is up to date. Mine is at r23237 (which was actually last checked in by derik).

#6 Updated by Derik Barseghian over 9 years ago

Thanks guys. I wasn't seeing a bunch of ptolemy updates from within eclipse. I've updated with ant update, and it's working for me now too. Sorry for the noise, closing.

#7 Updated by Derik Barseghian over 9 years ago

Hmm, reopening. So even with the ptolemy revision confusion aside, on a fresh checkout of the branch, this error doesn't happen from the command line, but does happen from a fresh import into eclipse. Not sure why...

#8 Updated by Derik Barseghian over 9 years ago

Also happens to me from trunk from within eclipse. Maybe another eclipse user can see if it happens to them too...

#9 Updated by Christopher Brooks over 9 years ago

I can reproduce this under Kepler trunk with Eclipse.

The workaround is to add ptolemy/src to the classpath.

How I did this is when I set up the Java Application:

Create a new Java Application Run Configuration by going to
Run/Run Configurations. In the main tab enter the project
"kepler" and Main class: "org.kepler.Kepler"

I then when to the classpath tab, clicked on the

kepler (default classpath)

leaf, clicked the "Advanced" button.

In the "Advanced Options" window, I selected "Add Folders"
and browsed to ptolemy/src.

So, I guess the Eclipse configuration needs to be updated
to include the source for each module in the classpath.

#10 Updated by Chad Berkley over 9 years ago

Hmm, the .classpath file does include the ptolemy src directory in the classpath. I'm currently looking into why this isn't working without adding it manually.

#11 Updated by Chad Berkley over 9 years ago

Christopher,

your fix does not work for me. Is there something else you did? The ptolemy-8.0/src directory is already in the classpath AFAICT. Are you working on the trunk or the branch?

#12 Updated by Christopher Brooks over 9 years ago

I did:

mkdir kepler-2.0
cd kepler-2.0

svn co https://code.kepler-project.org/code/kepler/branches/releases/release-branches/build-area-2.0 build-area

cd build-area
ant change-to -Dbranch=https://code.kepler-project.org/code/kepler/branches/releases/release-branches/ -Dsuite=kepler-2.0

As per Chad's email.

I then added ptolemy-8.0/src to the classpath as per my previous comment.
The kepler-2.0/.classpath file has
<classpathentry combineaccessrules="false" kind="src" path="/ptolemy-8.0"/>
which should probably be
<classpathentry combineaccessrules="false" kind="src" path="/ptolemy-8.0/src"/>

#13 Updated by debi staggs over 9 years ago

This happened for me today too, as I was going through testing the examples in the Documentation.

#14 Updated by debi staggs over 9 years ago

(In reply to comment #13)

This happened for me today too, as I was going through testing the examples in
the Documentation.

Nevermind, I just updated and it seems to be fixed now.

#15 Updated by Derik Barseghian over 9 years ago

Sorry to be a Reopener, but this is still happening for me. I had Ben try it out, and it happens to him too. From Christopher's comment above, it sounds like there's a ptolemy classpath problem in the eclipse build. David, can you look at this?

#16 Updated by Derik Barseghian over 9 years ago

Christopher's comment#9 works for me (beneath, and adjusting for, the trunk with the wrp suite, at least). However if I manually change the ptolemy line in kepler/.classpath as suggested in comment#11, I get build errors.

#17 Updated by David Welker over 9 years ago

Fixed. The problem was actually occurring at both the trunk and the 2.0 branch on a fresh checkout. Which makes sense.

#18 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4858

Also available in: Atom PDF