Project

General

Profile

Bug #4990

Ptolemy documentation missing

Added by Christopher Brooks about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
installer
Target version:
Start date:
05/07/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4990

Description

The Kepler-2.0-RC2 installer does not include files like ptII/doc/expression.pdf

To see this
1) start up Kepler,
2) Help -> Kepler documentation
3) Click on "Background information on Ptolemy
4) Click on "Documentation"
5) Click on "The Ptolemy II Expression Language"
6) Click on " available in PDF Format"
Note that you can get this page by dragging in an Expression
actor and clicking on Help.

It looks like the expressions.pdf file is not found, the stack trace is:

ptolemy.kernel.util.InvalidStateException: Failed to handle 'jar:file:/Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar!/doc/expressions.pdf#in_browser':
Because:
Could not find 'jar:file:/Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar!/doc/expressions.pdf#in_browser'
at ptolemy.actor.gui.BrowserTableau.show(BrowserTableau.java:172)
at ptolemy.actor.gui.Configuration.createPrimaryTableau(Configuration.java:582)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:875)
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:281)
at javax.swing.JEditorPane.fireHyperlinkUpdate(JEditorPane.java:320)
at javax.swing.text.html.HTMLEditorKit$LinkController.activateLink(HTMLEditorKit.java:827)
at javax.swing.text.html.HTMLEditorKit$LinkController.mouseClicked(HTMLEditorKit.java:637)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:212)
at java.awt.Component.processMouseEvent(Component.java:5605)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3129)
at java.awt.Component.processEvent(Component.java:5367)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3945)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)
Caused by: java.io.FileNotFoundException: Could not find 'jar:file:/Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar!/doc/expressions.pdf#in_browser'
at ptolemy.actor.gui.JNLPUtilities._lookupJarURL(JNLPUtilities.java:257)
at ptolemy.actor.gui.JNLPUtilities.saveJarURLAsTempFile(JNLPUtilities.java:155)
at ptolemy.actor.gui.BrowserTableau.show(BrowserTableau.java:136)
... 26 more
Caused by: java.io.FileNotFoundException: Could not find 'jar:file:/Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar!/doc/expressions.pdf#in_browser'
at ptolemy.actor.gui.JNLPUtilities._lookupJarURL(JNLPUtilities.java:257)
at ptolemy.actor.gui.JNLPUtilities.saveJarURLAsTempFile(JNLPUtilities.java:155)
at ptolemy.actor.gui.BrowserTableau.show(BrowserTableau.java:136)
at ptolemy.actor.gui.Configuration.createPrimaryTableau(Configuration.java:582)
at ptolemy.actor.gui.Configuration.openModel(Configuration.java:875)
at ptolemy.actor.gui.HTMLViewer.hyperlinkUpdate(HTMLViewer.java:281)
at javax.swing.JEditorPane.fireHyperlinkUpdate(JEditorPane.java:320)
at javax.swing.text.html.HTMLEditorKit$LinkController.activateLink(HTMLEditorKit.java:827)
at javax.swing.text.html.HTMLEditorKit$LinkController.mouseClicked(HTMLEditorKit.java:637)
at java.awt.AWTEventMulticaster.mouseClicked(AWTEventMulticaster.java:212)
at java.awt.Component.processMouseEvent(Component.java:5605)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3129)
at java.awt.Component.processEvent(Component.java:5367)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3945)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

It looks like there is a
/Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar that has a doc/expressions.pdf file in it.

bash-3.2$ jar -tvf /Applications/Kepler-2.0-RC2/Kepler.app/Kepler/ptolemy-8.0.0/target/ptolemy-8.0.jar | grep expressions.pdf
1704045 Fri Apr 30 13:29:40 PDT 2010 doc/expressions.pdf

It could be the #in_browser, I'll take a look.


Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolved04/19/2010

Blocks Kepler - Bug #4994: ant installer fails with "Invalid directory 'dir' ... outreach-2.0.0/resources"Resolved05/07/2010

History

#1 Updated by Christopher Brooks about 9 years ago

Fixed!

It turns out that the links in the ptII/doc/mainVergilPtinyKepler.htm file were
incorrect. I added some tests to ptolemy.actor.gui.HTMLAbout that will check for
this sort of problem.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4990

Also available in: Atom PDF