Project

General

Profile

Bug #4994

ant installer fails with "Invalid directory 'dir' ... outreach-2.0.0/resources"

Added by Christopher Brooks over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
05/07/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4994

Description

Working from the instructions at
https://kepler-project.org/developers/teams/build/building-kepler-installers
and using Kepler-2.0 instead of the devel trunk, I have problems with
"ant install"

mkdir kepler-2.0
cd kepler-2.0
svn co https://code.kepler-project.org/code/kepler/releases/release-branches/build-area-2.0/ build-area
cd build-area
ant change-to -Dsuite=kepler-2.0
ant clean-cache
ant eclipse
ant installer

Fails with:
--start--
[installer] Appending packs from the outreach-2.0 module.
[installer] Appending packs from the r-2.0 module.
[installer] Appending packs from the ptolemy-8.0 module.
[installer] basedirPath: /Users/cxh/src/kepler-2.0
[installer] Filtering out non-used OS elements.
[installer] Writing installer file to /Users/cxh/src/kepler-2.0/build-area/installer/install.xml

BUILD FAILED
/Users/cxh/src/kepler-2.0/build-area/build.xml:337: The following error occurred while executing this line:
/Users/cxh/src/kepler-2.0/build-area/build.xml:361: com.izforge.izpack.compiler.CompilerException: installer/install.xml:252: Invalid directory 'dir': /Users/cxh/src/kepler-2.0/outreach-2.0.0/resources
--end--

build-area/installer/install.xml is generated by the build process and includes
a reference to outreach-2.0.0, which does not exist. outreach-2.0 does
exist.

See also
http://mercury.nceas.ucsb.edu/kepler/pipermail/kepler-users/2010-April/002154.html

A test suite would help with this sort of problem.


Related issues

Blocked by Kepler - Bug #4943: RC5 Installer Tracking BugResolved04/19/2010

Blocked by Kepler - Bug #4990: Ptolemy documentation missingResolved05/07/2010

History

#1 Updated by Christopher Brooks over 9 years ago

Until I can build an installer, I can't fix bug #4990.

#2 Updated by David Welker about 9 years ago

At this point, building installers is meant for releases. Later on, I would like to automate the entire install process and ensure that it works in all three target environments. However, there is no intent to do so before 2.0.0. Closing the bug.

#3 Updated by Christopher Brooks about 9 years ago

In the Kepler-2.0 tree.
Running "ant" yields

[exec]  installer                       Builds the Kepler installers for Windows and Mac using IzPack.

Users will run "ant installer", they already have and reported errors.

Either "ant installer" should work or running "ant" should not
mention "ant installer" or clearly indicate that
it won't work.

Also https://kepler-project.org/developers/teams/build/building-kepler-installers
should be updated.
Until "ant installer" works, this bug should remain open.

Under Mac OS, "ant installer" fails with:

build-winexe:
[launch4j] Compiling resources
[launch4j] Linking
[launch4j] Successfully created /Users/cxh/src/kepler-2.0/build-area/installer/../../kepler.exe
[echo] **Building Windows Installer********
[installer] Copying documentation files to configs dir.
[installer] copying documentation from build-area/target/documentation to common-2.0/configs/ptolemy/configs/kepler
[installer] Appending packs from the outreach-2.0 module.
[installer] Appending packs from the r-2.0 module.
[installer] basedirPath: /Users/cxh/src/kepler-2.0
[installer] filterOutNonUsedOS() windows
[installer] Filtering out non-used OS elements.
[installer] Done filtering out non-used OS elements.
[installer] Writing installer file to /Users/cxh/src/kepler-2.0/build-area/installer/install.xml
[izpack] ERROR: 'The content of elements must consist of well-formed character data or markup.'
[izpack] ERROR: 'com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.'
[izpack] javax.xml.transform.TransformerException: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:673)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[izpack] Caused by: javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:515)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] ... 36 more
[izpack] Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:397)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] ... 37 more
[izpack] ---------
[izpack] javax.xml.transform.TransformerException: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:515)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[izpack] Caused by: com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:397)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] ... 37 more
[izpack] ---------
[izpack] com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:397)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[izpack] ---------
[izpack] org.xml.sax.SAXParseException: The content of elements must consist of well-formed character data or markup.
[izpack] at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)
[izpack] at org.apache.xerces.util.ErrorHandlerWrapper.fatalError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLScanner.reportFatalError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
[izpack] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
[izpack] at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
[izpack] at org.xml.sax.helpers.XMLFilterImpl.parse(XMLFilterImpl.java:333)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:391)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[izpack] ---------
[izpack] com.sun.org.apache.xml.internal.utils.WrappedRuntimeException: The content of elements must consist of well-formed character data or markup.
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:397)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)
[izpack] ---------
[izpack] org.xml.sax.SAXParseException: The content of elements must consist of well-formed character data or markup.
[izpack] at org.apache.xerces.util.ErrorHandlerWrapper.createSAXParseException(Unknown Source)
[izpack] at org.apache.xerces.util.ErrorHandlerWrapper.fatalError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLScanner.reportFatalError(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContentDispatcher.dispatch(Unknown Source)
[izpack] at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(Unknown Source)
[izpack] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
[izpack] at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
[izpack] at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
[izpack] at org.xml.sax.helpers.XMLFilterImpl.parse(XMLFilterImpl.java:333)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:391)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.dom.XSLTCDTMManager.getDTM(XSLTCDTMManager.java:231)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.getDOM(TransformerImpl.java:493)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:663)
[izpack] at com.sun.org.apache.xalan.internal.xsltc.trax.TransformerImpl.transform(TransformerImpl.java:300)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parseLineNrFromInputSource(Unknown Source)
[izpack] at com.izforge.izpack.adaptator.impl.XMLParser.parse(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.getXMLTree(Unknown Source)
[izpack] at com.izforge.izpack.compiler.CompilerConfig.executeCompiler(Unknown Source)
[izpack] at com.izforge.izpack.ant.IzPackTask.execute(Unknown Source)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.GeneratedMethodAccessor10.invoke(Unknown Source)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:38)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:416)
[izpack] at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
[izpack] at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[izpack] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[izpack] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[izpack] at java.lang.reflect.Method.invoke(Method.java:592)
[izpack] at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
[izpack] at org.apache.tools.ant.Task.perform(Task.java:348)
[izpack] at org.apache.tools.ant.Target.execute(Target.java:357)
[izpack] at org.apache.tools.ant.Target.performTasks(Target.java:385)
[izpack] at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
[izpack] at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
[izpack] at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
[izpack] at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
[izpack] at org.apache.tools.ant.Main.runBuild(Main.java:758)
[izpack] at org.apache.tools.ant.Main.startAnt(Main.java:217)
[izpack] at org.apache.tools.ant.launch.Launcher.run(Launcher.java:257)
[izpack] at org.apache.tools.ant.launch.Launcher.main(Launcher.java:104)

BUILD FAILED
/Users/cxh/src/kepler-2.0/build-area/build.xml:338: The following error occurred while executing this line:
/Users/cxh/src/kepler-2.0/build-area/build.xml:362: java.lang.NullPointerException

Total time: 13 seconds
bash-3.2$

#4 Updated by David Welker about 9 years ago

Running "ant" to list the commands no longer lists the ant installer command. Closing this bug.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4994

Also available in: Atom PDF