Project

General

Profile

Bug #5029

Parameter changes can be committed without clicking the commit button

Added by Sean Riddle about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
05/25/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5029

Description

1) Double-click on an actor and change a parameter.
2) Click the add button to trigger the "add parameter" dialog
3) Click Cancel

At this point, you're dumped back to the canvas, and your alteration to the parameter of the actor has been committed. Seems like the preferred behavior is either dumping the user back to the canvas with all changes rolled back, or (even better) just return the user to the normal parameter change dialog after they're done with the add parameter dialog.

I've managed to produce this on the RC3 installer on Windows XP, and on the Kepler trunk on a Mac.


Related issues

Has duplicate Kepler - Bug #4869: changes made to workflows during dialogs before committing (Edit Parameters/Cancel)In Progress03/04/2010

History

#1 Updated by Christopher Brooks about 9 years ago

This is a duplicate of 4869. Fixing this before Kepler-2.0 is not
advised as the problem involves modal dialogs. A failure here would
lock up Kepler.

I agree that it is a bug though.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5029

Also available in: Atom PDF