Project

General

Profile

Bug #504

incorrect rendering of eml-physical in xml editor (eml Beta6)

Added by Matthew Brooke over 18 years ago. Updated almost 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
05/14/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
504

Description

How to reproduce:
From package editor, select an eml-physical module (eml Beta6) and start to
edit in the xml editor. In the tree view, right click on the last entry
("SEQUENCE"), and select "duplicate". Fill out both sequences with a value
for "fieldStartColumn" and choose "fieldDelimiter" and enter a value.
Save the data.

Result:
Data gets written to XML file correctly (therefore displays directly from
metacat) - but when module is re-opened in Morpho's xml editor, only
one "SEQUENCE" element is shown, instead of two. However, this single element
contains both "fieldStartColumn" entries, and only one "CHOICE" entry, but
this CHOICE entry now contains 3 choices - an empty "fieldWidth" element, and
both of the "fieldDelimiter" elements entered earlier.

History

#1 Updated by Dan Higgins almost 18 years ago

not a common problem since eml-physical usually not edited by user - moved to 1.3

#2 Updated by Dan Higgins almost 17 years ago

New editor in Morpo 1.4.1 fixes this problem

#3 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 504

Also available in: Atom PDF