Project

General

Profile

Bug #5193

Open menu items should be merged into one

Added by Christopher Brooks about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
09/29/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5193

Description

Help | Kepler Documentation
says:

"All listed demos are in the KeplerData/workflows/module/outreach-2.X.Y/demos/getting-started"

When I go to that directory, only 04-HelloWorld.kar is selectable?
I can't load .xml files?

The directory

bash-3.2$ ls ~/KeplerData/workflows/module/outreach-2.1/demos/getting-started
00-StatisticalSummary.xml 08-CommandLine_2.xml
01-SimpleAddition.xml 09-XMLDataTransformation.xml
02-LotkaVolterraPredatorPrey.xml HelloWorld.class
03-ImageDisplay.xml HelloWorld.jar
04-HelloWorld.kar HelloWorld.java
04-HelloWorld.xml XSLTSample.xsl
05-LinearRegression.xml mollusc_abundance.txt
06-WebService.xml sampleEntry.xml
07-CommandLine_1.xml species-distribution.jpg
bash-3.2$

History

#1 Updated by Derik Barseghian about 9 years ago

Sounds like you're using File=>Open... when you want to be using File=>Open MoML...

#2 Updated by Christopher Brooks about 9 years ago

Every first time user will try File | Open and not understand why
they cannot choose the .xml demos.

This sort of failure really discourages potential users.

What we have now is a set of demos that are not easily viewed and a
complex set of open dialogs.

At a minimum, there should be kar files for the demos so that File | Open works.

#3 Updated by Derik Barseghian about 9 years ago

I agree having to understand the different open options is an annoyance, but this was a problem in 2.0 as well, it's just that users who primarily used kars had the bad end of the stick in 2.0, and now it's reversed.
As I've previously said, in 2.2 I think the open options should be combined into one Open... menu that can handle kars, moml, and urls (and we should add support for opening, through this new open menu, kars at a url).

Creating KAR versions of all the demos has significant ramifications for the text and screenshots in our documentation, and shouldn't be a part of 2.1. The group would have to agree to nuking the xml versions, so that we only have to maintain one copy of a given workflow. We should improve how KARs work within Kepler (there is currently no unambiguous way to tell which KAR you're inside) before updating all the text and screenshots. Since these documentation changes represent a significant amount of work, and we should avoid doing it twice.

#4 Updated by Derik Barseghian about 9 years ago

Giving this bug a new title and retargeting to 2.2.

#5 Updated by David Welker about 9 years ago

I have merged the functionality of these two open dialogs into one dialog.

Closing.

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5193

Also available in: Atom PDF