Project

General

Profile

Bug #533

new File|Open to accomodate new UI design

Added by Matt Jones over 17 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
06/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
533

Description

The "File|Open..." menu will now display a list of data packages that are owned
by the user in a dialog box. This replaces the current "ownerQuery" panel that
is displayed in the main morpho content pane. The dialog will have a radio
button that lets the user switch between displaying all owned packages, just
those that are local, or just those on metacat. Be sure to consider how this
list can be configured to use hierarchical folders as described in bug 306.
When selected, the package will be opened in a window as described in bug 532.

The search window will produce result lists that are structured in the same way
as the open dialog (again, see bug 306). When one does a search, double
clicking on a search result (a package) should open it in the same way that the
File|Open dialog works.


Related issues

Is duplicate of Morpho - Bug #534: new File|Open to accomodate new UI designResolved06/13/2002

Blocks Morpho - Bug #535: screenshots and UML design for new UIResolved06/13/2002

Blocked by Morpho - Bug #356: resolve icon usability issuesResolved11/30/2001

Blocked by Morpho - Bug #306: [RFE] folder views to organize data packagesIn Progress10/23/2001

History

#1 Updated by Matt Jones over 17 years ago

  • Bug 534 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones over 17 years ago

Need to redesign or eliminate icons for this new view of the data (bug 356).
Also note the new dependency on bug 306 in terms of creating folder views.

#3 Updated by Jing Tao about 17 years ago

File|Open dialog is in morpho now. It looks as same as our design and
functionalities works fine.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 533

Also available in: Atom PDF