Project

General

Profile

Bug #5361

Animate at Runtime broken

Added by Ron Mak over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
03/30/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5361

Description

Upon starting Kepler, the following error appears on the console:

Exception trying to create an Action for classname: <org.kepler.gui.RunWithFeedbackChkBoxAction>

This is caused by a circular reference. KeplerMenuHandler.pack() executes

[1] menuMapper = new MenuMapper((TableauFrame) t)

The call to the MenuMapper constructor eventually leads to calling the contructor for class RunWithFeedbackChkBoxAction. This latter constructor executes

[2] MenuMapper menuMapper = (MenuMapper) parent.getAlternateTopPack()
.getObject(null);

In [2], parent.getAlternateTopPack() returns the same instance of KeplerMenuHandler which is still executing [1], and the call to getObject(null) returns menuMapper which is null since statement [1] has not yet completed. A null pointer exception is thrown. The Animate at Runtime item does not appear in the Tools menu.

History

#1 Updated by Aaron Aaron over 8 years ago

The "Animate at Runtime" menu item is working again. It appears in the Tools menu.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5361

Also available in: Atom PDF