Project

General

Profile

Bug #5438

missed menubar and misformed buttons without text

Added by unknown unknown almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
07/11/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5438

Description

Like the summary says.
I will attach a screenshot that shows that the buttons "Search","Advanc.." and "Sources" are completely misformed and without text.

My platform is:
openSUSE11.4 with kernel3.0rc5
openjdk6 b22
no additional plugins

kepler misformed buttons.jpeg (80.8 KB) kepler misformed buttons.jpeg unknown unknown, 07/11/2011 06:58 AM
kepler console output (5.33 KB) kepler console output unknown unknown, 07/11/2011 07:29 AM

History

#1 Updated by unknown unknown almost 8 years ago

It´s worser than I´ve thought.

The getting started guide shows that there must be a menubar with FILE... and so on at the top of the Keplr GUI, but as the screenshot shows there is no menue bar and without it no basic functionallity, which makes Kepler for me near useless.

#3 Updated by Daniel Crawl almost 8 years ago

How does this error occur? e.g., starting Kepler?

I found a similar exception to the one shown in your console output when I tried to view the documentation for more than one actor. I checked in a fix for that error; let us know if you still have problems.

#4 Updated by unknown unknown almost 8 years ago

It´s native on just starting kepler. Nothing to do other. And it is always there.
I´ve wondering that I am the first that brings this to you.

What your fix affect:

I´am new to kepler(first day!), so I don´t know where to go to get it.
Is there a beta or developer or trunk version/repro?
Can you point me on? Than I test.

Please no compilation journeys;)

#5 Updated by Daniel Crawl almost 8 years ago

I would try Sun/Oracle's JDK instead of openjdk.

#6 Updated by unknown unknown almost 8 years ago

Yes, that it is an option, but I do not prefer.
The official cause can be found here:

http://blogs.oracle.com/henrik/entry/moving_to_openjdk_as_the

in which oracle announce that openjdk7 will become the reference implementation of java instead of the sun/oracle jdk, which was it until now(will be the 28th of this month).
In addition: IBM has started to work on openjdk and only there several month ago.

So the things are moving there.

The other cause is that in linux systems the openjdk is better integrated than the oracle one. AFAIK in debian oracle jdk is not available in the regular repositories.
On openSUSE it is in the repros, but I´ve seen the last time only the v6u25 and not the v6u26 and to install it manually is a not so good think->I had some trouble with that what a oracle database install on my system do with the configurations(bad behavior).

So it might be intended in the future to support also openjdk.
If you want I can do some testing jobs for this for kepler.

#7 Updated by unknown unknown almost 8 years ago

I son´t like it to say, but you have some serious problems with your program:

I´ve tried it with sun jdk6u25 on windows vista ---> the same problem is there, no diff to openjdk!

WoW! There must be a hugh part of all user that try to start first time with kepler that quit is instantly!

Only a suggestion: test some basic behavior of kepler, also on different jdk´s, which kan be done easily with eclipse, you now.

My greetings and good luck.

P.S : I have shown this to Michael Vyskocil, before I tested kepler with sunjdk6u25. He works at openSUSE on java. He also see the problem in your code and not in the jdk.

#8 Updated by unknown unknown almost 8 years ago

When I remember right I seen in the documentation that you use MAC OS.
VirtualBox got stable with version 4.1, also for development(I do so). It works also on MacOS and can give you easy access to other platforms.

#9 Updated by Derik Barseghian almost 8 years ago

Sorry to hear you're still having problems, thanks for reporting them.

Can you tell us which version of kepler you're trying? Are you building from svn trunk, or which version installer did you use?

We develop and test against the 3 main platforms, focusing on OS X, Ubuntu, and Windows (mainly XP and 7). However we've tested and installed Kepler on Vista many times in the past, and have not seen this problem before.

Someone just tested Fedora with IcedTea and had no problems.

I've just tried kepler on Window XP with oracle's java 1.6.0_26 and can't get this problem to occur.

We'll try to get someone to test on openSUSE and/or Vista soon...

#10 Updated by unknown unknown almost 8 years ago

Q:Can you tell us which version of kepler you're trying?

A:I have here still kepler2.2.0, from
https://kepler-project.org/users/downloads

The linux variant.

Q:Are you building from
svn trunk, or which version installer did you use?

A:No, I don´t build it by myself until now and I do not use a installer.
I use extract the archiv and execute kepler.sh from shell:

/home/user/Software/kepler-2.2-linux-> ./kepler.sh

#11 Updated by unknown unknown almost 8 years ago

On vista I have also the file from:

https://kepler-project.org/users/downloads

the windows version.

#12 Updated by Christopher Brooks almost 8 years ago

Under RedHat, I was able to run Kepler-2.2.0 under Sun JDK 1.6.0_21

However, as expected, OpenJDK 1.6.0 fails

bash-3.2$ java version
java version "1.6.0"
OpenJDK Runtime Environment (build 1.6.0-b09)
OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)
bash-3.2$ ./kepler.sh
JVM Memory = 5m 512m
[null] Checking for patches...
[null] Building Kars...
[null] Ran additional initialization for module core from class org.kepler.module.core.Initialize
[null] Ran additional initialization for module gui from class org.kepler.module.gui.Initialize
[null] X connection to localhost:10.0 broken (explicit kill or server shutdown).
Exception in thread "main" Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
Caused by: Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 1 more
Caused by: Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 3 more
--
Nested Exception ---
Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
Caused by: Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 3 more
--- Nested Exception ---
Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
bash-3.2$

It is unfortunate that command that was executed is not returned, nor is the
error message.

Ptolemy II, when run outside of Kepler, starts up fine with OpenJDK . . .

#13 Updated by Daniel Crawl almost 8 years ago

I installed openSUSE 11.4, and had no problems running Kepler 2.2 from the tarball. The default java is:

java version "1.6.0_20"
OpenJDK Runtime Environment (IcedTea6 1.9.7) (suse-1.2.1-x86_64)
OpenJDK 64-Bit Server VM (build 19.0-b09, mixed mode)

I also tested on Fedora Core 15, and had no problems. The default java is:

java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.2) (fedora-58.1.10.2.fc15-i386)
OpenJDK Client VM (build 20.0-b11, mixed mode)

Yes, both of these are IcedTea, instead of vanilla OpenJDK. However, IcedTea is the default java distribution for openSUSE 11.4 and FC15. Is there a reason for not using that?

Christopher, were you testing on RHEL?

It would be nice to fix this for the upcoming 2.3 release, but if it cannot easily be reproduced...

#14 Updated by Christopher Brooks almost 8 years ago

On sisyphus.eecs.berkeley.edu, we are running:

[bldmastr@sisyphus test]$ rpm -qa redhat-release
redhat-release-5Client-5.4.0.3
[bldmastr@sisyphus test]$ cat /etc/redhat-release
Red Hat Enterprise Linux Client release 5.4 (Tikanga)

#15 Updated by Daniel Crawl almost 8 years ago

I was able to reproduce the original problem (missing menus and blank buttons) by using IcedTea OpenJDK and $LANG set to something other than 'en_US'. This was also reported in 5270.

As a workaround for Kepler 2.2, it should work if you set $LANG:

export LANG=en_US
./kepler.sh

Christopher reported not being able to start Kepler using non-IcedTea OpenJDK, which is probably a different issue.

#16 Updated by unknown unknown almost 8 years ago

Huhuhuhuuuuuu, I´ve tried the workaround in comment 15.
It works here now.

When this is common(and looks like) than there must be indeed many users out there(it was also there on sun/oracle jdk on vista), which did not come up with kepler.

Thank you Daniel Crawl for not giving up!

#17 Updated by Daniel Crawl almost 8 years ago

Fixed at r28184.

I was also able to reproduce using Oracle JDK, which does not appear to use $LANG for the locale.

I'll create a separate bug for running with non-IcedTea.

#18 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5438

Also available in: Atom PDF