Project

General

Profile

Bug #5451

Componets ->(right mouse) View Dokumentation causes NameDuplicationException

Added by unknown unknown about 8 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
documentation
Target version:
Start date:
08/05/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5451

Description

When I try to call "View Documentation" (right mouse click on a component->"View Documetation") and there is already a help window open from another comonent, than Kepler popup an error window and throw a exeption:

[null] ptolemy.kernel.util.NameDuplicationException: Attempt to insert object named "DocEffigy" into container named ".configuration.directory.effigy3", which already contains an object with that name.
[null] at ptolemy.kernel.util.NamedList.append(NamedList.java:133)
[null] at ptolemy.kernel.CompositeEntity._addEntity(CompositeEntity.java:2122)
[null] at ptolemy.kernel.ComponentEntity.setContainer(ComponentEntity.java:518)
[null] at ptolemy.kernel.CompositeEntity.setContainer(CompositeEntity.java:1857)
[null] at ptolemy.actor.gui.Effigy.setContainer(Effigy.java:401)
[null] at ptolemy.kernel.ComponentEntity.<init>(ComponentEntity.java:106)
[null] at ptolemy.kernel.CompositeEntity.<init>(CompositeEntity.java:164)
[null] at ptolemy.actor.gui.Effigy.<init>(Effigy.java:133)
[null] at ptolemy.vergil.actor.DocEffigy.<init>(DocEffigy.java:60)
[null] at org.kepler.gui.ShowDocumentationAction.actionPerformed(ShowDocumentationAction.java:136)
[null] at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2012)
[null] at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2335)
[null] at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
[null] at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
[null] at javax.swing.AbstractButton.doClick(AbstractButton.java:374)
[null] at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:829)
[null] at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:873)
[null] at java.awt.Component.processMouseEvent(Component.java:6268)
[null] at javax.swing.JComponent.processMouseEvent(JComponent.java:3267)
[null] at java.awt.Component.processEvent(Component.java:6033)
[null] at java.awt.Container.processEvent(Container.java:2045)
[null] at java.awt.Component.dispatchEventImpl(Component.java:4629)
[null] at java.awt.Container.dispatchEventImpl(Container.java:2103)
[null] at java.awt.Component.dispatchEvent(Component.java:4455)
[null] at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4633)
[null] at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4297)
[null] at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4227)
[null] at java.awt.Container.dispatchEventImpl(Container.java:2089)
[null] at java.awt.Window.dispatchEventImpl(Window.java:2517)
[null] at java.awt.Component.dispatchEvent(Component.java:4455)
[null] at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:649)
[null] at java.awt.EventQueue.access$000(EventQueue.java:96)
[null] at java.awt.EventQueue$1.run(EventQueue.java:608)
[null] at java.awt.EventQueue$1.run(EventQueue.java:606)
[null] at java.security.AccessController.doPrivileged(Native Method)
[null] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
[null] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:116)
[null] at java.awt.EventQueue$2.run(EventQueue.java:622)
[null] at java.awt.EventQueue$2.run(EventQueue.java:620)
[null] at java.security.AccessController.doPrivileged(Native Method)
[null] at java.security.AccessControlContext$1.doIntersectionPrivilege(AccessControlContext.java:105)
[null] at java.awt.EventQueue.dispatchEvent(EventQueue.java:619)
[null] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:275)
[null] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:200)
[null] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
[null] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:185)
[null] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:177)
[null] at java.awt.EventDispatchThread.run(EventDispatchThread.java:138)
[null] Using default context menu stuff for class: ptolemy.kernel.ComponentEntity
[null] Using default context menu stuff for class: ptolemy.kernel.ComponentEntity
[null] Using default context menu stuff for class: ptolemy.kernel.ComponentEntity

anova ASC.jpeg (280 KB) anova ASC.jpeg unknown unknown, 08/05/2011 08:19 AM
kepler frozen state (12.8 KB) kepler frozen state unknown unknown, 08/05/2011 09:06 AM

History

#1 Updated by unknown unknown about 8 years ago

Platform:
openSUSE11.4 kernel3.0 64bit
IcedTea/Openjdk6b22
Kepler2.2.0

#2 Updated by unknown unknown about 8 years ago

I´ve seen that you intend to run several workflows with own windows in Kepler.

So it may be useful to attach the documentation window in the associated workflow window(like in eclipse based applications) and switch the content of that incorporated documentation window when the user choose an other part of the documentation(an other component). -> one help window each workflow window; switching content of the help windows in the context of there workflows).

#3 Updated by Christopher Brooks about 8 years ago

I can't reproduce this.
1) Download Kepler-2.2 for Mac OS X or build from sources
2) Start Kepler
3) Actors -> CoreActors,kar Drag in ANOVA
4) Drag in ASC To Raw
5) Right click on ANOVA, select Documentation -> Display
6) Right click on ASC To Raw, select Documentation -> Display.

BTW - when building from source, the documentation does not exist,
I had to run "ant javadoc"

#5 Updated by Christopher Brooks about 8 years ago

Interesting.
Just to be clear, you are running with Kepler-2.2 under Linux and
not a Kepler distribution that you built from sources, right?

Also, in your bug description, you say

(right mouse click on a component->"View Documetation")

Under Kepler-2.2 and Mac OS X, I have Documentation -> Display.
What is the exact text of the menu choice you are using.

Also, you have only one instance of Kepler running, right?
We have another bug#5430 that is for multiple instances of Kepler.

Can you send me precise instructions on what you do to get the bug?
You may want to try a reboot and a clean install of Kepler.

#6 Updated by unknown unknown about 8 years ago

Just to be clear, you are running with Kepler-2.2 under Linux and
not a Kepler distribution that you built from sources, right?

Yes, it is your pre-build Kepler-2.2 from you website and not a self build from source.

The only think I change for starting is:

>export LANG=en-US
>./kepler.sh

Because of:

http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5438

#7 Updated by unknown unknown about 8 years ago

Also, you have only one instance of Kepler running, right?

Yes, I can produce it with only one instance.

#8 Updated by unknown unknown about 8 years ago

Can you send me precise instructions on what you do to get the bug?
You may want to try a reboot and a clean install of Kepler.

A rebbot is already done->all keeps like it was.
A new installation of kepler seems not indicated, because today is the first day I can really work with kepler, so no misconfiguration could happen until now, and other explanations..., well..., I prepare a virtual enviroment because of other stuff which will be similar to my host-> I install kepler there also, but don´t put much hope in an explanation with data corruption->mostly it doesn´t help.

#9 Updated by unknown unknown about 8 years ago

Under Kepler-2.2 and Mac OS X, I have Documentation -> Display.
What is the exact text of the menu choice you are using.

"View Documentation" like descripted.
Under this option there is "View LSID", when that helps with orientation.

#10 Updated by unknown unknown about 8 years ago

Can you send me precise instructions on what you do to get the bug?

1.Start Kepler
2.choose "ANOVA" with right click
3.choose "View Documentation" in the appeared menu.
4.choose "ASC To Raw" with right click
5.choose "View Documentation" in the appeared menu.
->See the bug.

#12 Updated by Daniel Crawl about 8 years ago

This bug was fixed in r27824, which was after Kepler 2.2:

r27824 | crawl | 2011-07-11 12:36:48 -0700 (Mon, 11 Jul 2011) | 3 lines

bug fix: use unique name to prevent NameDuplicationException
see http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5438

See comment 3 in 5438.

I can confirm that the problem exists in 2.2, but not the trunk. For Kepler 2.2 on mac, if you run Kepler.app the exceptions do not appear in the terminal window. However, they do appear if you run kepler.sh.

#13 Updated by unknown unknown about 8 years ago

Than,.. it would be better when I switch to your developer version/build from source.

#14 Updated by unknown unknown about 8 years ago

@ Daniel Crawl
I do not know how much download you have daily, but
may be it could help when somebody add a hint on the download page:
Something like the "export LANG=en-US" thing until a minor release can be published.

#15 Updated by unknown unknown about 8 years ago

I´ve just downloaded trunk(revision 28231) and get it on with ant.

Jup, the bug is fixed.

So, I´m not sure what is usual here: Closing when it is fixed in trunk or when it´s out in stable-download?!

#16 Updated by Christopher Brooks about 8 years ago

We usually close bugs when the bug is fixed in the devel tree.
We don't seem to follow a formal policy, perhaps we should . . .

#17 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5451

Also available in: Atom PDF