Project

General

Profile

Bug #5505

Kepler-2.3 installer should create directory named "Kepler-2.3", not "Kepler"

Added by Christopher Brooks over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
installer
Target version:
Start date:
10/05/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5505

Description

When installing https://code.kepler-project.org/code/kepler/releases/test-installers/Kepler-2.3.dmg
I get a window that prompts me to drag the Kepler icon to the applications folder.

The folder should be named "Kepler-2.3", not "Kepler", so that it
is obvious which version is installed and so that multiple versions of
Kepler may be installed.

If the user already has a Kepler folder, what happens?

This is a feature request, not a bug, but I find it odd to have applications
that have no notion of version number in the directory name.

History

#1 Updated by Christopher Brooks over 7 years ago

I'm setting the target to 2.3.0, feel free to change the target.

#2 Updated by Derik Barseghian over 7 years ago

Whoops, didn't notice a mid-air collision when posting my comment last night:

I made this change intentionally at r28648:
By default, no longer install into versioned directories, install in the same
place each time, overwriting as necessary: /Applications/Kepler/ and C:\Program
Files\Kepler

The windows installer prompts you to overwrite an existing Kepler dir if it
exists. On Mac, the OS prompts you to overwrite an old copy of the app if it
exists.

While some applications install into dirs with version or year numbers (eg
Office) in the name, a lot of others install in the same place every time, I
believe with the idea being that most users want 1 copy of an application, the
latest one. Advanced users can modify the dir name to maintain different
copies.

A benefit of not keeping the version number in the name is that with this
release forward it helps avoid failure to start kepler due to missing modules,
see http://bugzilla.ecoinformatics.org/show_bug.cgi?id=5458#c6 for background.

A downside of this current state: possible wasted bandwidth. E.g. let's say you
download a kepler 2.4 installer in the future, and overwrite your 2.3 install.
If you try to open a 2.3 kar in strict mode (not that many people should want
to do this), you will have to download 2.3 (the 2.3 modules will go into your
KeplerData\kepler.modules dir).

#3 Updated by Christopher Brooks over 7 years ago

I disagree with this, but you can close this if you want.

Note that (I think) the Kepler Windows installer created a kepler-2.3 directory.

Having the installer install directories that do not have a version number
results in a world of hurt down the road when users install releases over each
other and get a nasty frankenstein's monster of a product that increases
the amount of support.

#4 Updated by Matt Jones over 7 years ago

Derik and I went back and forth about this last month. For me, one of the compelling reasons to go with a versionless directory is that Kepler now has the feature of switching versions via the ModuleManager on the fly. So, I might install 2.3, but then load a workflow in strict mode that switches the installed version of Kepler to 2.1. It would be weird to have this 2.1 install be pressent in a 2.3 labeled directory.

Also, there are efficiencies to be had by installing all of the modules in one location, so they can be found and need not be needlessly re-downloaded when the MM switches from version to version.

Finally, I think it is the installer/MM's job to transparently switch from version to version, and that the 'cruft' from previous versions really shouldn't/can't get in the way. If it does, then the MM has a bug, because it is supposed to by design be able to switch from one version to another seamlessly.

So I voted for plain "kepler" as the install directory.

#5 Updated by Derik Barseghian over 7 years ago

rc1 created a versioned dir name, rc2 doesn't. Based on this and bug#5506 I think you're using rc1 and not rc2 -- I just relaunched the windows installer and it says Sep 30, 2011, and doesn't have the 2.0 text.

Re: frankenstein scenario, this isn't an issue for the mac, the old dir is first wiped.

On windows it currently is (I was under the mistaken idea it wasn't). IzPack says it will "possibly overwrite" existing files. I've just run an experiment: renamed my Kepler-2.2 to Kepler, and then installed 2.3. This leaves the 2.2 modules in place in the Kepler app dir. This is good on the one hand, wrt not having to download these modules again. However it's bad in others, it makes the windows and mac install behavior even more different, and when I launch kepler after installing 2.3, 2.2 comes up -- there must be another MM bug here.

A few possibilities come to mind:
I can revert to including the version number in the name. We then lose the benefit of getting rid of the MM GUI having to come up when starting old app versions due to missing module errors.

I can look into having IzPack delete the app dir before installing. I'm not clear on if this is supported. I see a request for it in 2005, but in a quick look at the izpack issue tracker haven't found info on it.
http://permalink.gmane.org/gmane.comp.java.izpack.cvs/515

#6 Updated by Derik Barseghian over 7 years ago

I didn't see a quick solution using IzPack, and since time is short, I've reverted to including the version number in the folder name at r28909-12. Maybe we can revisit this in the future. Closing.

(In reply to comment #5)

rc1 created a versioned dir name, rc2 doesn't. Based on this and bug#5506 I
think you're using rc1 and not rc2 -- I just relaunched the windows installer
and it says Sep 30, 2011, and doesn't have the 2.0 text.

Re: frankenstein scenario, this isn't an issue for the mac, the old dir is
first wiped.

On windows it currently is (I was under the mistaken idea it wasn't). IzPack
says it will "possibly overwrite" existing files. I've just run an experiment:
renamed my Kepler-2.2 to Kepler, and then installed 2.3. This leaves the 2.2
modules in place in the Kepler app dir. This is good on the one hand, wrt not
having to download these modules again. However it's bad in others, it makes
the windows and mac install behavior even more different, and when I launch
kepler after installing 2.3, 2.2 comes up -- there must be another MM bug here.

A few possibilities come to mind:
I can revert to including the version number in the name. We then lose the
benefit of getting rid of the MM GUI having to come up when starting old app
versions due to missing module errors.

I can look into having IzPack delete the app dir before installing. I'm not
clear on if this is supported. I see a request for it in 2005, but in a quick
look at the izpack issue tracker haven't found info on it.
http://permalink.gmane.org/gmane.comp.java.izpack.cvs/515

#7 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 5505

Also available in: Atom PDF