Project

General

Profile

Bug #611

rewrite help documentation

Added by Matt Jones over 17 years ago. Updated about 16 years ago.

Status:
Resolved
Priority:
Low
Assignee:
Category:
morpho - general
Target version:
Start date:
09/30/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
611

Description

The current version of Morpho (pre-1.2) has been changed substantially enough
that all of the help documentation is now useless. We need to rewrite the
documentation that Eric and Dan originally did, but explain everything in terms
of the new UI. Dan can take the lead on making sure that this is done, but we
agreed it would be very useful if a non-developer could help write and edit the
documentation to be sure it is maximally useful to seminar participants -- we've
identified Christy as someone who might be able to play this role. Matt will
contact Christy and Sandy to see if this is feasible.


Related issues

Has duplicate Morpho - Bug #1470: Morpho User's Guide ProblemsResolved04/12/2004

History

#1 Updated by Dan Higgins over 17 years ago

A first cut at Morpho helo has been created thanks to the help of Christ Bowles.
The html help files have been added to CVS.

There is obviously additional work that can be done, but I am postponing
addiitona to Morpho 1.3

#2 Updated by Saurabh Garg over 16 years ago

Comments in morpho-feedback-20040122.doc in /doc/devs/ by Andrea Chadden:

In Morpho Help window (left-hand side of Table of Contents), ‘Creating New
Package’ selection should be changed to ‘Creating a New Package’.

Next comments pertain to various pages of the Morpho User Guide:
Red exclamation points are a great addition (they are very useful in catching
the reader’s eye) but should all be the same size throughout the document.
(The Morpho Screen): “The next three buttons are enabled only when…The enable
you”; should read “The next three buttons are enabled only when…They enable
you”.
“As with the other panels, this panel can be resized by dragging….and can be
hidden or expanded fully clicking..” should read: “should be expanded by fully
clicking..”
(Search Interface paragraph): “Similarly to uploading a data package” should
read “Similar to uploading a data package”.
(Creating New Package paragraph): Data Package Wizard instructions has
line: “You will also be given a chance to upload you package”; should be “your
package”.
(New Datapackage Wizard): On People and Organizations screen, change “the
person or organization who are to be credited” to “the persons or organizations
who are to be credited”.

Next comments pertain to Morpho Help / Morpho User Guide / Getting Started
screen:
First paragraph warns, “Be sure to remember your user name and password”.
Perhaps this screen should provide advice for cases where the user DOES forget
one of these items….
Create a Morpho Profile: Sentence starting and ending “This profile allows you
to use Morpho locally…(see preceding paragraph) will allow you to create, edit,
and search for datasets on the KNB’. Should this be amended to read “On the KNB
via the Metacat”? or similar wording? Metacat isn’t talked about much overall
in the Morpho User Guide.
Text above screen image reads: “Enter your profile name, name, and password as
follows:” Misleading as password is not actually entered on this screen.
(Search Interface paragraph): “See more on permissions”. Should “permissions”
be a hot link to a detailed discussion of permissions in Morpho?

Next comments pertain to various pages of the Morpho User Guide:
(Status Bar paragraph) If “Morpho does not currently support SSL connections”
as stated, how could the security icon in lower right of main Morpho screen
ever be “locked and green” as stated? And what is an SSL connection for us lay
people?
(Data Table Panel paragraph) As stated: “You can click and edit data directly…
After editing… click...’cancel’ to undo”. Please clarify the specifics of undo
behavior (e.g., does it undo the last change? All previous changes?) We have
noticed that undo behavior is not internally consistent within the package
(Reeves). ((Does this mean that clicking undo does not yield the same activity
each time?))
(Search Interface section) A more detailed description of the ‘data package
search process’ would help the novice Morpho user. The Search screen
label ‘Query Title’ may be misleading to users with relational database
experience, and perhaps should just be called “Search Title”.
(Spatial Search paragraph): paragraph should clarify whether the search will
return data packages that partially overlap the search box, or ONLY those
packages that fall completely within the search box.
(Creating New Data Package section): Note that paragraphs describing the Data
Package Wizard screens do not have the heading lines that the Text Import
Wizard screens have (Text Import Wizard – Screen 1). Can they be made
consistent?
(Creating New Data Package section): References to Morpho Package Editor and
EML Editor need to be reinforced with (links to) instructions for using the
editors.
(Text Import Wizard – Screen 2): “ The next import page allows you….columns.
Hopefully you know this information”. What if the user does not know? Can we
help them find out?
(Editing an Existing Package section): It would be helpful to give information
and examples of how the Morpho Editor tree diagram is used to enter and modify
metadata fields. See also Reeves comment along these lines……
(Editing a Table section): First paragraph reads in part: “Use the Table Editor
to…’ Yet the screen calls this the Morpho Editor. Which term is correct? Same
comment applies to the ‘General Purpose Description Editor’.
(Morpho Editor section): Line reads: “Most of the fields on the right
side...are editable”… ‘Editable’ not a word, how about “are able to be edited”?
(Morpho Editor section): Under the Technical Notes section, how about a hot
link to the FAQ section?

Next comments apply to the Frequently Asked Questions window:
Second FAQ refers to upgrade to Morpho version 1.2. Should this refer to
version 1.5?
Final FAQ (#7) refers to checking the computer’s performance parameters (e.g.,
RAM, clock speed). Should FAQ also tell them how to actually do so?
Suggest adding a FAQ that answers the question: “What if I have problems using
Morpho?” With one answer being Morpho Tech Support points of contact.
Websites connecting to following links: KNB Home / Data / People / etc… have
not been checked for accuracy/spelling/grammar (some typos, etc. have been
noticed).

#3 Updated by Dan Higgins about 16 years ago

documentation being handled in another bug

  • This bug has been marked as a duplicate of 1470 ***

#4 Updated by Redmine Admin about 7 years ago

Original Bugzilla ID was 611

Also available in: Atom PDF