Project

General

Profile

Bug #668

streamline party entry

Added by Matt Jones almost 20 years ago. Updated over 19 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
11/06/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
668

Description

Entering contact informtion for people is common and time-consuming. We could
substantially streamline this process using several mechanisms. In order of
complexity:

1) Collect contact information about the user in the profile. When they type
their last name in a eml-party surname field, pop up a window asking if they
want to use their own info, and fill it in for them if they say yes.

2) When someone enters a surname in, look it up in ldap, either on each
keystroke, or when they move to the next field. This may be something we want
to ask metacat to do. Pop up a dialog that doesn't prevent them from continuing
to enter the name, and ask if they want to use one of the ldap entries. If they
say yes, format the entry in EML and fill in the values for them.

3) Keep a list of entries in memory for paries that the user has entered
previously in the current package, or in all packages. When they type in a
surname, pop up a dialog as in (2) with this list and ask if they mean one of
the existing people. If that person is already in the document, add a reference
to that person if using eml 2. Otherwise, add the person in as an eml block.


Related issues

Has duplicate Morpho - Bug #669: streamline entry for responsible partyResolved11/06/2002

History

#1 Updated by Matt Jones over 19 years ago

Bug accidentally entered twice. Marking this one as a duplicate.

  • This bug has been marked as a duplicate of 669 ***

#2 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 668

Also available in: Atom PDF