Project

General

Profile

Bug #669

streamline entry for responsible party

Added by Matt Jones almost 20 years ago. Updated over 18 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
morpho - general
Target version:
Start date:
11/06/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
669

Description

Entering contact informtion for people and other responsible parties is common
and time-consuming. We could substantially streamline this process using
several mechanisms. Here are some possibilities:

1) Collect contact information about the user in the profile. When they type
their last name in a eml-party surname field, pop up a window asking if they
want to use their own info, and fill it in for them if they say yes.

2) When someone enters a surname in, look it up in ldap, either on each
keystroke, or when they move to the next field. This may be something we want
to ask metacat to do. Pop up a dialog that doesn't prevent them from continuing
to enter the name, and ask if they want to use one of the ldap entries. If they
say yes, format the entry in EML and fill in the values for them.

3) Keep a list of entries in memory for paries that the user has entered
previously in the current package, or in all packages. When they type in
surname, pop up a dialog as in (2) with this list and ask if they mean one of
the existing people. If that person is already in the document, add a reference
to that person if using eml 2. Otherwise, add the person in as an eml block.


Related issues

Is duplicate of Morpho - Bug #253: use profile info for default text in wizardResolved07/12/2001

Is duplicate of Morpho - Bug #668: streamline party entryResolved11/06/2002

History

#1 Updated by Matt Jones almost 20 years ago

  • Bug 253 has been marked as a duplicate of this bug. ***

#2 Updated by Matt Jones over 19 years ago

  • Bug 668 has been marked as a duplicate of this bug. ***

#3 Updated by Matt Jones almost 19 years ago

Retargeting at 1.5, as at least one mechanism for streamlining party entry has
been prototyped. Thus release may not implement all of the described mechanisms
for party entry, but it should improve at least some of the entries.

#4 Updated by Saurabh Garg over 18 years ago

Comments in morpho-feedback-20040122.doc in /doc/devs/ by Andrea Chadden:

1. When entering people information into the Owner / Contact / Associated Party
details screens, the feature allowing user to select previously entered
personnel information should be made more explicit, and possibly offered on the
previous wizard screen.

My comments: Need to discuss how to make it more explicit. It was on previous
wizard screen earlier. But it was put on the current screen as more
functionality will be added with this widget on this screen

2. Also, when entering people information into the Owner / Contact / Associated
Party details screens, make it possible to select and then modify an existing
entry to create a NEW entry (as when two individuals have the same contact
information but you want to change more than just their name)

My comments: We have discussed about adding this functionality without risking
the possibility of making the wizard too complex for the user.

#5 Updated by Saurabh Garg over 18 years ago

Following remaining issues witht his screen:

1. The references could point to a different document. This is a bug and needs
to be resolved before release.

2. Other enhancement is to give user the choice between using previous entry as
a reference or as a copy. The text for the dialogue box will be tricky and needs
to be decided. I will send an email with possible text for the dialogue box.

#6 Updated by Saurabh Garg over 18 years ago

From Bug# 1243

In DPW "Research Project", when adding personnel I chose an existing person
from the list, and when I clicked ok the party did not show up in the list of
personnel. Even entering a person manually after that did not result in an entry
in the list. This is probably a bug.

------- Additional Comment #4 From Saurabh Garg 2003-12-30 09:20 -------

fixed 8 and 9
in 10: Entering a person manually now adds it to the list. If picked from the
list, it doesnt add to the list because it is supposed to be a reference. This
can be changed if wanted.

------- Additional Comment #5 From Matt Jones 2003-12-30 09:35 -------

Regarding 10) I think that even references should show up in the list, as the
user needs some visual indication that the entry exists, and needs a way to
delete the entry if they decide to. The only problem comes with editing: you
can either a) disable editing for references, or b) enable editing but edit the
original party entry wherever it exists. I prefer b) because it gives the user
more options, but you'll need to indicate to them that changing the party's info
on the reference screen will effectively change it throughout the document.

#7 Updated by Chad Berkley over 18 years ago

matthew has added an extensive framework for pulling party information from
different packages via references. You can now get contact information from
either other contacts inside the current package and you can import contacts
from other packages that the user has access to. This bug will now be closed,
but the relevant items that have not been completed will be transfered to
another 'postpone' bug.

#8 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 669

Also available in: Atom PDF