Project

General

Profile

Bug #833

Management page needed with full ability to modify accounts

Added by Michael Lee almost 20 years ago. Updated about 16 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
userAlter
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
833

Description

ML design


Related issues

Is duplicate of VegBank - Bug #814: [1000] Management accounts??Closed11/13/2002

Is duplicate of VegBank - Bug #827: [1020] Management accounts??:Delete UserClosed11/13/2002

Is duplicate of VegBank - Bug #828: [1030] Management accounts??:Update user statusClosed11/13/2002

Is duplicate of VegBank - Bug #831: [1016] Management accounts??Resolved11/13/2002

History

#1 Updated by Michael Lee over 19 years ago

  • Bug 814 has been marked as a duplicate of this bug. ***

#2 Updated by Michael Lee over 19 years ago

  • Bug 827 has been marked as a duplicate of this bug. ***

#3 Updated by Michael Lee over 19 years ago

  • Bug 828 has been marked as a duplicate of this bug. ***

#4 Updated by Michael Lee almost 19 years ago

Page needed where managers (highest cert. level) can:

view all users
certify users
delete plots
delete users
restart tomcat? (tricky, if tomcat is down, the page might not work?)
see system status- log report or memory usage..?

#5 Updated by Michael Lee almost 19 years ago

  • Bug 831 has been marked as a duplicate of this bug. ***

#6 Updated by Michael Lee over 16 years ago

Managers also probably need to be able to delete parties and projects that accidentally get added. Additionally, we may want to be able to combine duplicate parties, projects, plants, etc.

We need the ability for management to extend, add, or remove embargoes and fuzz/unfuzz plot locations.

#7 Updated by Michael Lee over 16 years ago

if for some reason the denorms and XML cache, etc. is out of sync, management should be able to reset them. But shouldn't need manager to do that, just if something weird happens, management page shuold have that ability, too.

#8 Updated by Chad Berkley over 16 years ago

you can now do the actions with the X next to them.

X view all users
X certify users
delete plots
X delete users
restart tomcat

with regards to restarting tomcat from the webapp, I don't think this is really possible or desirable. Anyone restarting tomcat should have root access to the server and have the admin skills that go along with having root access.

#9 Updated by Chad Berkley over 16 years ago

The delete plots functionality was already implemented, but you had to type in the plot ids of the plots you wanted to delete one by one. I made it a bit easier and added a 'delete' link to the search result list which only shows up if you're logged in as an admin. Now each of the requested functions are available to admins.

There is some question as to whether we want to enable deletion of plots, which will be discussed in a conference call today.

Also, even though the plot is deleted, the observation that the plot is a part of still shows up in the search results. I'm not sure how to deal with this or if we even want to.

#10 Updated by Chad Berkley about 16 years ago

I'm going to close this bug because I don't think there is anything else left to do with it. Restarting tomcat from the tomcat operated web interface is not an option.

#11 Updated by Michael Lee about 16 years ago

Would it be possible to add to the management page at:
http://aldo.vegbank.org/vegbank/AdminMenu.do

the ability to run accessionGen (on all null accessionCodes in the db only)
the ability to run denorms (nulls only) or force an entire update (including the XML cache)

Sometimes these fail after a load, resulting in unpopulated accessionCodes or denorm fields. Currently, there is no easy way to rectify that.

?????

#12 Updated by Michael Lee about 16 years ago

we can now run accessionGen and denormGen, plus keyword gen from the /usr/vegbank/bin dir. This should work for admin purposes. A guide to using this dir should be created for Bob, et al.

#13 Updated by Michael Lee about 16 years ago

guide exists and you have to run those from the command line.

#14 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 833

Also available in: Atom PDF