Project

General

Profile

Bug #847

evaluate: User view & output stylesheets

Added by Michael Lee almost 20 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
misc
Target version:
Start date:
11/13/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
847

Description

"---"


Related issues

Is duplicate of VegBank - Bug #577: Full plot stylesheetClosed08/28/2002

Is duplicate of VegBank - Bug #857: Evaluate: View a plot, quick viewResolved11/13/2002

Has duplicate VegBank - Bug #1220: Need systematic approach to viewing all data in databaseResolved11/21/2003

History

#1 Updated by Michael Lee almost 20 years ago

  • Bug 577 has been marked as a duplicate of this bug. ***

#2 Updated by Michael Lee almost 20 years ago

Currently when a user selects a plot to view from the vegbank system, the user
is sent a document that is transformed by an old stylesheet designed by JHH.
This stylesheet needs to be redone inorder for users to see the data in a
format expected by an ecologist.

After this stylesheet is completed, it needs to be given to John/Gabe for
implementation.

#3 Updated by Robert Peet over 19 years ago

ML will design these stylesheets and pass them past RKP for evaluation and
review. This is relatively urgent and must be in 1.0

#4 Updated by Michael Lee over 19 years ago

The stylesheets have been redesigned for plot view -- short and long forms and
can be accessed by querying for plots, then click on the "book" or "report" for
long and short views of the plot, respectively. I pass this bug back to Bob for
his approval/suggestions about the view of the plot. OR click to URL:
http://vegbank.nceas.ucsb.edu/framework/servlet/DataRequestServlet?requestDataFormatType=html&clientType=browser&requestDataType=vegPlot&resultType=full&queryType=simple&plotId=1273
for full view, and for short view:
http://vegbank.nceas.ucsb.edu/framework/servlet/DataRequestServlet?requestDataFormatType=html&clientType=browser&requestDataType=vegPlot&resultType=summary&queryType=simple&plotId=1273

From a phone conversation we had at one time about this form, I remember that
Bob suggested the following:
-- Cover needs to indicate that it is in percent

Also, the view of plots can be upgraded when the XML doc for plots is upgraded.

#5 Updated by Michael Lee over 19 years ago

There are also copies of the old view of a plot as well as the new views of a
plot on bug 847, which has been resolved as it is contained within this bug.

#6 Updated by Michael Lee over 19 years ago

  • Bug 857 has been marked as a duplicate of this bug. ***

#7 Updated by Robert Peet over 19 years ago

Links to the stylesheets are not now working. Need to be fixed before I can
evaluate.

#8 Updated by Michael Lee over 19 years ago

Not sure why the query page isn't working now, but in the meantime, Bob can
evaluation what the pages look like (fonts slightly off due to stylesheet being
ignored- not sure why, but it looks a bit tighter on vegbank). Header and
footer are also old, but you get the idea:
http://bugzilla.ecoinformatics.org/attachment.cgi?id=68&action=view

is the summary and
http://bugzilla.ecoinformatics.org/attachment.cgi?id=69&action=view
is the comprehensive view.
These are attachments to bug 857.

These will need updating after our XML gets updated.

#9 Updated by Michael Lee almost 19 years ago

this bug has been passed by the better and higher goals of the very humble bug 1220

  • This bug has been marked as a duplicate of 1220 ***

#10 Updated by Michael Lee over 17 years ago

changed from components that are to be deleted to "misc" so that bugs don't get
deleted with component. Sorry for all the email.

#11 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 847

Also available in: Atom PDF