Project

General

Profile

Bug #1220

Need systematic approach to viewing all data in database

Added by Michael Lee almost 19 years ago. Updated over 17 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
misc
Target version:
Start date:
11/21/2003
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1220

Description

This could be done with XML-XSL, but we would prefer give it a shot with
javabeans which are more efficient. Currently (Nov 21,2003) the metadata
viewing functions use the genericDispatcher to return beans, which are called
recursively throughout the page. We have had problems with the stability of
this approach. Better would be to have nested beans returned by one request.

This bug shall serve as a holding spot for any discussion on this, and should be
closed when the generic solution has been found and some parts of the database
viewable via this method. Then other bugs can be made to direct us as to what
exactly needs viewing.


Related issues

Is duplicate of VegBank - Bug #847: evaluate: User view & output stylesheetsResolved11/13/2002

Blocked by VegBank - Bug #804: Interpret community in extant plotResolved11/13/2002

Blocked by VegBank - Bug #807: Interpret taxon in extant plotResolved11/13/2002

Blocked by VegBank - Bug #1221: Systematic solution to querying dataResolved11/21/2003

Blocked by VegBank - Bug #794: Evaluate viewing forms and input forms for VegBank MetadataResolved11/13/2002

History

#1 Updated by Michael Lee almost 19 years ago

Making the 5 "major" bugs critical so that bugzilla highlights them in red, how
nice.

#2 Updated by Michael Lee almost 19 years ago

  • Bug 847 has been marked as a duplicate of this bug. ***

#3 Updated by Michael Lee over 18 years ago

not required for Feb29 release.

#4 Updated by P. Anderson over 18 years ago

Per the initial request, I'd say this bug can be closed. We have the
GenericDispatch action which works well, labeled as "Summary Report" on the plot
query results page. Improvements to the display are possible, but as stated
originally they should be new bugs.

#5 Updated by Michael Lee over 18 years ago

Perhaps this bug is unclear. We need a way to view any data in the database by
simply calling a URL and perhaps a set of PK/AccessionCodes to view.

Something like:
vegbank.org/vegbank/view.do?accCode=VB.CC.123
and
vegbank.org/vegbank/view.do?tbl=party&PKs=1,4,14,56

--it wouldn't have to be as transparent as this, but this gives the idea.

We need to also think about the different views that these should produce and
name them. For example, summary view (standard spreadsheet view), comprehensive
view (field1: value1 <br/> field2: value2 <br/> etc.), PK translation (instead
of party_ID=45, we get "Jo Smith"), etc.

URLs add &view=summary

This is really important because as we accomplish new functionality, we want to
be able to see it. Right now, it's hard to really see what's going on in the db
if we make some nice change.

#6 Updated by P. Anderson over 18 years ago

Apache's powerful URL rewriting capabilities gives us lots of options here. For one, I'd prefer to keep
the script name out of the URL entirely. e.g.

  1. View an entity by accession code in comprehensive (full) mode
    http://vegbank.org/get/full/VB.CC.123
  1. View a list of parties by PK
    http://vegbank.org/get/full/party/1,4,14,56
  1. Summary view
    http://vegbank.org/get/summary/party/1,4,14,56
  1. Get raw XML for a given accession code
    http://vegbank.org/get/xml/VB.CC.123
  1. Get raw XML for a given list of PKs
    http://vegbank.org/get/xml/party/1,4,14,56

General form:

/get/ (AC | 'full' | 'summary' | 'xml') / (entity_name | AC)

Something like that.

#7 Updated by Michael Lee about 18 years ago

  • Bug 1221 has been marked as a duplicate of this bug. ***

#8 Updated by P. Anderson about 18 years ago

Squashing this bug with our first custom JSP tag, <vegbank:get> which uses
configurable SQL queries to populate a list or single bean or map in a JSP page.
First use was quite effective.

#9 Updated by Michael Lee about 18 years ago

see http://gyro.nceas.ucsb.edu:8080/vegbank/forms/aux_role_viewall.jsp as an
example, created in 20 min by PMark and me

#10 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 1220

Also available in: Atom PDF