Project

General

Profile

Bug #1552

Dependence of NCEAS registry on Admin database

Added by Saurabh Garg over 16 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
registry
Target version:
Start date:
05/04/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1552

Description

This is reported by Sandy:
She had problems accessing the registry when she was in Washington DC and
giving demos of the registry to NSF.
Everything was working fine except for the register dataset page for NCEAS. So
other functions like search etc were working properly - but
http://knb.ecoinformatics.org/cgi-bin/register-dataset.cgi?cfg=nceas was
showing up as blank page.
I think (and I told her the same thing) that it was the admin database that was
causing the problem. The project list is generated from the admin database and
if admin database is down - we get a blank page for the url
http://knb.ecoinformatics.org/cgi-bin/register-dataset.cgi?cfg=nceas.

Solution: We should probably make the project list independent of the admin
database... (and/or) we should put some kind of error recovery in case admin
database is down.


Related issues

Is duplicate of Metacat - Bug #2785: NCEAS project list does not update from the NCEAS admin databaseResolved02/28/2007

History

#1 Updated by Matt Jones over 16 years ago

The right thing to do is:

1) Fix the admin database so it doesn't go down so regularly. This is an
identified problem.

2) We should have error handling code in the registry that detects the error and
at least explains the problem to the user. I don't think we should have a
separate project list, but I suppose that caching it would be an option that we
could use when the db is down. The key is that we would want to keep this list
refreshed every time a successful connection is made, as it changes daily.

#2 Updated by Shaun Walbridge about 13 years ago

  • Bug 2785 has been marked as a duplicate of this bug. ***

#3 Updated by Shaun Walbridge about 13 years ago

Callie's comment from dupe:

The ability to "search" on the list with somekind of "auto-field"
is mentioned and would be helpful. I don't know if that is something that can
be quickly and easily added to this fix.

#4 Updated by Shaun Walbridge almost 12 years ago

A number of changes to the AdminDB and the registry make this connection more reliable, and the error cases are well handled. Moving the UI issue mentioned into a separate bug (bug 3742).

#5 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 1552

Also available in: Atom PDF