Project

General

Profile

Bug #1695

Multi-node EcoGrid search for Kepler

Added by Jing Tao almost 15 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
09/17/2004
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1695

Description

Currently, the end points and namespace for EcoGrid search in kepler is hard
coded in configure file. The reason we do that is because we haven't have a
ecogrid services registry yet. Now Bing is working on registry and we should
make kepler can search registry and get ecogrid end pionts dynamiclly.

Here is some basic throughs:
We need two search button:
One is still quick search and will search the default end points and namespace
according configure file. This option is for people has its favorite ecogrid nodes.

The second one named registry search. Click that button and kepler will search
the registry nodes and get the ecogrid nodes info. Then kepler desplays metadata
of records in registry in a new frame. Metadata inlucdes node name, end points
and document namespace et al. User can choose endpoints and namespace by click
check box. Then do a search base on the choice and result set will be display
the resultset panel.

First step. I think we need do screenshot for it.


Related issues

Has duplicate Kepler - Bug #1655: DIALOGS: Implement New UI for Sources Dialog (was "integrate ecogrid registry into kepler ecogrid client")In Progress08/16/2004

History

#1 Updated by Chad Berkley over 14 years ago

dup of 1655

  • This bug has been marked as a duplicate of 1655 ***

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 1695

Also available in: Atom PDF