Project

General

Profile

Actions

Bug #1989

closed

JDK 1.5 Nullpointer exceptions when using HTML viewer (jdk1.5 Bug ID #5089077 ?)

Added by Matthew Brooke about 19 years ago. Updated almost 14 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - dsp
Target version:
Start date:
02/22/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
1989

Description

On startup screen, click "Create New Dataset" to launch wizard, then click
"Introduction to Ecological Metadata" link to open HTML viewer.

Any mouseover or resizing on the text pane results in streams and sreams of
nullpointer stacktraces that make the UI unresponsive.

Haven't looked in great detail ,but appears to be due to a known jdk1.5 bug (Bug
ID #5089077) - see:

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5089077

which occurs when relative text sizes are used in HTML documents

Possible fixes -

a) better way is to change the code to get rid of the exception (e.g, see
workaround shown at foot of bug page linked above)
b) least-desirable way is to edit HTML/CSS files so relative font sizes aren't
used (I'm guessing some fonts are set as 1em etc instead of 12px etc)

Actions #1

Updated by Matt Jones about 19 years ago

This is an important one to fix for the 1.6 release because JDK 1.5 is going to
be more and more common.

Actions #2

Updated by Saurabh Garg over 18 years ago

Not able to reproduce the problem. Tried with following jdk versions 1.5.0_02
and 1.5.0_03
Matthew's jdk version was 1.5.0_02

Actions #3

Updated by Saurabh Garg over 18 years ago

Matthew says able to reproduce the bug on machines where jalama plugin is
installed. Hence it is related to the Jalama plugin.

Decreasing priority and assigning bug to Matthew.

Actions #4

Updated by ben leinfelder almost 14 years ago

Are we even using the Jalama plugin?

Actions #5

Updated by Matt Jones almost 14 years ago

No, the Jalama plugin is way out of date, and we are not using it. This bug can be closed I think.

Actions #6

Updated by ben leinfelder almost 14 years ago

no more Jalama

Actions #7

Updated by Redmine Admin almost 11 years ago

Original Bugzilla ID was 1989

Actions

Also available in: Atom PDF