Project

General

Profile

Bug #2150

'Edit Custom Icon' menu item doesn't work

Added by Dan Higgins almost 14 years ago. Updated about 13 years ago.

Status:
Resolved
Priority:
Normal
Category:
interface
Target version:
Start date:
07/13/2005
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2150

Description

The 'Edit Custom Icon' item in the popup menu doesn't work in Kepler although it
does in PTII 5.0. The problem is that it uses the actor tree on the left in PTII
and Kepler has its own version. We should either remove the menu item or fix it.

History

#1 Updated by Matt Jones over 13 years ago

Probably should remove it as we are moving to custom SVG icons for everything.
Maybe we should allow the user to choose which icon to use for a new actor.

#2 Updated by Matthew Brooke over 13 years ago

Removed New->Icon Editor from File menu. Still need to remove 'Edit Custom Icon'
item from popup menu

#3 Updated by Christopher Brooks over 13 years ago

On this one, we need a better way to handle Kepler specific menus in the
Ptolemy classes that does not require duplicating the Ptolemy code.

One such way would be to use the configuration to configure the menu choices.
In this case, the menu comes from vergil/basic/WithIconGraphController.java.
We could modify that class so that it skips adding the menu if a the configuration
has a specific tag. At the minimum we need some naming conventions for these
tags. For example, if the configuration contained a property
"_menuActorEditIcon" that was set to false, then we would skip adding the
Edit Icon menu choices to the actor context menu. This is just a trivial
example. . .

Even better would be a way to use the configuration mechanism to configure the
context menus in a more generic fashion. The configuration should allow a user
to add new menu choices, change current menu choices and remove menu choices.

An alternative would be to use an entirely different menu management system,
but this seems like quite a bit of work. If we went that far, then perhaps
going to Eclipse would seem worth it?

Does anyone have any suggestions?

#4 Updated by Matthew Brooke about 13 years ago

re-implemented menus (in answer to Christopher's prev. comment), and have
removed the "custom icon" related menu items, since we currently do not want the
icons to be editable from within kepler (at least, not in the way ptii allowed it)

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 2150

Also available in: Atom PDF