Project

General

Profile

Bug #4069

Metacat Authenticated Query fails for specific user/group/dataset combinations

Added by Oliver Soong over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
data access
Target version:
Start date:
05/15/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4069

Description

The problem affects several datasets with similar access permissions, such as judithk.769.12.

These datasets are not publicly accessible, but access is granted to the kruger-tpc group:
[read] cn=kruger-tpc,o=NCEAS,dc=ecoinformatics,dc=org

My login is part of the group, and I can view the datasets through the KNB webpage and through Morpho.

If I enable the Metacat Authenticated Query in Kepler and provide my login credentials, I do not see the datasets. Regetz confirmed this, but he was able to search for a private dataset of his own. Derik also confirmed that he was able to access some private data. The problem occurs on OSX, linux, and Windows for both 1.x dev and 1.0.0.


Related issues

Blocks Kepler - Bug #3764: Kepler needs to support EML 2.1.0Resolved01/21/2009

History

#1 Updated by Jim Regetz over 10 years ago

(In reply to comment #0)

Regetz confirmed this, but he was able
to search for a private dataset of his own.

The data package that I own is actually public, so don't let that be a red herring. I don't think I have access to any non-public datasets other than the Kruger ones, so I can't actually say how general the problem is.

#2 Updated by ben leinfelder over 10 years ago

this is now an EML 2.1.0 document. Kepler does not yet have support for 2.1.0.
Will look into that - there is a bug for it already (now a blocker for this bug).
Note that we my need to push the issue on this so that we can do the TPCs before july

#3 Updated by ben leinfelder over 10 years ago

if you update from the development trunk, you should now have three different document types available for the KNB Authenticated Query (and regular query). Make sure 2.1.0 is checked - should be able to access the data package referenced in this ticket.
Note: the attribute metadata and the data (in particular) seem to be a bit dirty for this datapackage. I've had trouble using the "Preview" option after dragging the datasource to the canvas. It would be great to clean up the data on the server if possible, but it might be quicker to use the "As Cache File Name" to read the data tables into R actors.

#4 Updated by Oliver Soong over 10 years ago

Can you clarify the problems you're having with the Preview option? I know in some of the tables there are unusual characters. Shaun mentioned that the EML documents aren't specifying a character encoding (UTF-8 maybe?), so perhaps that has something to do with it.

#5 Updated by ben leinfelder over 10 years ago

it's not necessarily the Preview function per se - more that I can see many many errors about numeric format exceptions etc when the EML datasource is dragged to the canvas (backing DB tables are created to facilitate structured queries from the EML actors, but it only works if the data is clean). Stuff like:
java.lang.NumberFormatException: For input string: ">"
is a problem when the data is described as "numeric" but contains [human-understandable] things like great than and less than...

#6 Updated by Oliver Soong over 10 years ago

Oh, well there's also a problem with the table Woody_Vca_Sites.txt. The preview window wasn't working right probably because of fancy characters. Not to add more things to worry about.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4069

Also available in: Atom PDF