Project

General

Profile

Bug #4476

Tagging / Workflow Run Manager interaction problems

Added by Derik Barseghian over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
tagging
Target version:
Start date:
10/16/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4476

Description

There are some problems with Tagging /WRM interaction. We can add/refine this list as we go.

1) Displaying the tags associated with a particular run in the tagging UI when that run is selected -- they often disappear when you select something else (as they should) but then don't reappear when the row is reselected.

2) >1 rows may be selected, but if you tag at this point, only one row gets the tag. Likewise I imagine there's work to be done for showing all tags for all selected rows, and the logic for getting the right target when doing a remove.

3) Workflow tags aren't showing up in WRM. I'm working on this one.

History

#1 Updated by Derik Barseghian over 9 years ago

Looks like Sean has fixed #1.
I've fixed #3.

#2 still a problem.

#2 Updated by Sean Riddle over 9 years ago

An easy solution for now would be to disable tagging (probably changing the displayed tagging context to something like "range selected" or something) when multiple rows are selected. The other solution that jumps out at me would be to tag all the rows; this sounds more desirable. What do people think?

#3 Updated by Matt Jones over 9 years ago

Tagging all selected rows sounds more desirable to me. It would be common for someone to run a model a bunch of times and then want to tag a whole set, so multiple selection would be a natural thing to try in the UI.

#4 Updated by Sean Riddle over 9 years ago

Number 2 should also work now.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4476

Also available in: Atom PDF