Project

General

Profile

Bug #5066

Fix for ImageJ so that preferences are stored in an area other than the installation space. This may require a change to ImageJ source code.

Added by David Welker over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
06/30/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5066

Description

(2) Fix for ImageJ so that preferences are stored in an area other than the installation space. This may require a change to ImageJ source code.

The issue here is that the preferences are saved relative to the ImageJ jar file, and the jar file is often stored in a real-only area. Solving problem (1) will not solve this problem. A good solution if (1) is solved by downloading added modules in a local area would be to perhaps isolate ImageJ to its own module. Alternatively, the code of ImageJ could be changed to handle saving preferences differently, but this would cause maintenance issues.


Related issues

Has duplicate Kepler - Bug #5026: Error dialog pop up in RC3 when closing the ImageJ window after workflow execution.Resolved05/20/2010

Blocked by Kepler - Bug #5064: Kepler 2.1 Tracking BugNew06/30/2010

History

#1 Updated by Christopher Brooks over 9 years ago

Duplicate of 5026, though this bug has a better title than 5026. I'll update 5026.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5066

Also available in: Atom PDF