Project

General

Profile

Bug #5598

parameters appear as white boxes instead of dots

Added by Derik Barseghian about 7 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
workflow run manager
Target version:
Start date:
05/07/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5598

Description

Using the workflow run manager, one can download a remote workflow run kar, and then right click on the row and select Open to open the associated workflow. Under Windows 7, at least some of the time, if this workflow has parameters, they will appear as large white rectangles instead of dots. See attached screen shot.

white-rectangles-for-parameters.png (255 KB) white-rectangles-for-parameters.png Derik Barseghian, 05/07/2012 11:23 AM
ProblemDownloadingRemoteModel.png (32.8 KB) ProblemDownloadingRemoteModel.png Christopher Brooks, 08/24/2012 10:17 AM

History

#1 Updated by Christopher Brooks almost 7 years ago

I could not get the workflow run manager to work for me under Windows.

I found https://code.kepler-project.org/code/kepler/trunk/modules/workflow-run-manager/docs/workflow-run-manager.pdf

Under Windows Server 2008R2, I used the module manager to select
workflow­‐run-­manager-­2.3.

Kepler failed to restart, so I did ant change-to -Dsuite=workflow-run-manager
When I ran "ant run", the workflow run manager came up.
I logged in anonymously to the repository, selected TestSSHWithDisplay and
got a dialog about unsatisfied module dependencies.

Clicking on Force Open did nothing.

I'm out of time on this one, the bug seems to be Kepler-specific.
We could push this off to post 2.4.

I believe the problem is that the _icon is an Attribute, where it should
be a ValueIcon or some other class.

Below are details.

ptolemy/vergil/icon/EditorIcon.java says:

An icon is the visual representation of an entity or attribute.           
The visual representation is a Diva Figure. This class is an attribute
that serves as a factory for such figures. This base class creates the
figure by composing the figures of any contained attributes that have
icons. If there are no such contained attributes, then it creates a
default figure that is a white rectangle. This class also provides
a facility for generating a Swing icon (i.e. an instance of
javax.swing.Icon) from that figure (the createIcon() method).

2009-06-08 22:56 cxh

  • [r54262]
    /trunk/ptolemy/domains/wireless/demo/EvaderAndPursuer/EvaderAndPursuer.xml:
    Fixed radioRange property, it was showing up as a white box

The diff is:

- <property name="radioRange" class="ptolemy.data.expr.Parameter" value="50.0">
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
- <property name="_color" class="ptolemy.actor.gui.ColorAttribute" value="{0.0, 0.0, 1.0, 1.0}">
- </property>
- </property>
- <property name="_smallIconDescription" class="ptolemy.kernel.util.SingletonConfigurableAttribute">
- <configure>
- <svg>
- <text x="20" style="font-size:14; font-family:SansSerif; fill:blue" y="20">-P-</text>
- </svg>
- </configure>
- </property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
- </property>
- <property name="_location" class="ptolemy.kernel.util.Location" value="495.0, 40.0">
- </property>
- </property>
<property name="annotation" class="ptolemy.kernel.util.Attribute">
<property name="_hideName" class="ptolemy.kernel.util.SingletonAttribute">
</property>
@ -76,8 +59,27 @
</property>
<property name="_vergilZoomFactor" class="ptolemy.data.expr.ExpertParameter" value="1.0">
</property>
- <property name="_vergilCenter" class="ptolemy.data.expr.ExpertParameter" value="{379.0, 274.5}">
+ <property name="_vergilCenter" class="ptolemy.data.expr.ExpertParameter" value="{397.5, 276.0}">
</property>
+ <property name="RadioRange" class="ptolemy.data.expr.Parameter" value="50.0">
+ <property name="_hideName" class="ptolemy.kernel.util.SingletonAttribute">
+ </property>
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
+ <property name="_color" class="ptolemy.actor.gui.ColorAttribute" value="{0.0, 0.0, 1.0, 1.0}">
+ </property>
+ </property>
+ <property name="_smallIconDescription" class="ptolemy.kernel.util.SingletonConfigurableAttribute">
+ <configure>
+ <svg>
+ <text x="20" style="font-size:14; font-family:SansSerif; fill:blue" y="20">-P-</text>
+ </svg>
+ </configure>
+ </property>
+ <property name="_editorFactory" class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
+ </property>
+ <property name="_location" class="ptolemy.kernel.util.Location" value="[530.0, 40.0]">
+ </property>
+ </property>

It looks like the primary changes are that in the newer version:
_icon is a ValueIcon not an simple Attribute
_editorFactory is a VisibleParameterEditorFactory, not a simple Attribute

2006-05-11 17:53 cxh

  • [r42388]
    /trunk/ptolemy/domains/ct/demo/Pendulum3D/Pendulum3D.xml:
    Adjusted sizes, fixed white box problem with parameters

The diffs are like:

@ -25,7 +25,7 @
<property name="phi" class="ptolemy.data.expr.Parameter" value="PI/6">
<property name="_hideName" class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute" value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>
@ -36,7 +36,7 @
</svg>
</configure>
</property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
+ <property name="_editorFactory" class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
</property>
<property name="_location" class="ptolemy.kernel.util.Location" value="[200.0, 65.0]">
</property>
@ -44,7 +44,7 @
<property name="theta" class="ptolemy.data.expr.Parameter" value="PI/10">
<property name="_hideName" class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute" value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>
@ -55,7 +55,7 @
</svg>
</configure>
</property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
+ <property name="_editorFactory" class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
</property>
<property name="_location" class="ptolemy.kernel.util.Location" value="[200.0, 40.0]">
</property>
@ -63,7 +63,7 @
<property name="phiDot" class="ptolemy.data.expr.Parameter" value="1.0">
<property name="_hideName" class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute" value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>

#3 Updated by Derik Barseghian almost 7 years ago

I was able to replicate the WRM fail to Force Open issue w/ this run kar. I opened bug#5697 for it.

(In reply to comment #1)

I could not get the workflow run manager to work for me under Windows.

I found
https://code.kepler-project.org/code/kepler/trunk/modules/workflow-run-manager/docs/workflow-run-manager.pdf

Under Windows Server 2008R2, I used the module manager to select
workflow­‐run-­manager-­2.3.

Kepler failed to restart, so I did ant change-to -Dsuite=workflow-run-manager
When I ran "ant run", the workflow run manager came up.
I logged in anonymously to the repository, selected TestSSHWithDisplay and
got a dialog about unsatisfied module dependencies.

Clicking on Force Open did nothing.

I'm out of time on this one, the bug seems to be Kepler-specific.
We could push this off to post 2.4.

I believe the problem is that the _icon is an Attribute, where it should
be a ValueIcon or some other class.

Below are details.

ptolemy/vergil/icon/EditorIcon.java says:

An icon is the visual representation of an entity or attribute.
The visual representation is a Diva Figure. This class is an attribute
that serves as a factory for such figures. This base class creates the
figure by composing the figures of any contained attributes that have
icons. If there are no such contained attributes, then it creates a
default figure that is a white rectangle. This class also provides
a facility for generating a Swing icon (i.e. an instance of
javax.swing.Icon) from that figure (the createIcon() method).

2009-06-08 22:56 cxh

  • [r54262]

/trunk/ptolemy/domains/wireless/demo/EvaderAndPursuer/EvaderAndPursuer.xml:
Fixed radioRange property, it was showing up as a white box

The diff is:

- <property name="radioRange" class="ptolemy.data.expr.Parameter"
value="50.0">
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
- <property name="_color" class="ptolemy.actor.gui.ColorAttribute"
value="{0.0, 0.0, 1.0, 1.0}">
- </property>
- </property>
- <property name="_smallIconDescription"
class="ptolemy.kernel.util.SingletonConfigurableAttribute">
- <configure>
- <svg>
- <text x="20" style="font-size:14; font-family:SansSerif; fill:blue"
y="20">P</text>
- </svg>
- </configure>
- </property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
- </property>
- <property name="_location" class="ptolemy.kernel.util.Location"
value="495.0, 40.0">
- </property>
- </property>
<property name="annotation" class="ptolemy.kernel.util.Attribute">
<property name="_hideName"
class="ptolemy.kernel.util.SingletonAttribute">
</property>
@ -76,8 +59,27 @
</property>
<property name="_vergilZoomFactor"
class="ptolemy.data.expr.ExpertParameter" value="1.0">
</property>
- <property name="_vergilCenter" class="ptolemy.data.expr.ExpertParameter"
value="{379.0, 274.5}">
+ <property name="_vergilCenter" class="ptolemy.data.expr.ExpertParameter"
value="{397.5, 276.0}">
</property>
+ <property name="RadioRange" class="ptolemy.data.expr.Parameter"
value="50.0">
+ <property name="_hideName"
class="ptolemy.kernel.util.SingletonAttribute">
+ </property>
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
+ <property name="_color" class="ptolemy.actor.gui.ColorAttribute"
value="{0.0, 0.0, 1.0, 1.0}">
+ </property>
+ </property>
+ <property name="_smallIconDescription"
class="ptolemy.kernel.util.SingletonConfigurableAttribute">
+ <configure>
+ <svg>
+ <text x="20" style="font-size:14; font-family:SansSerif; fill:blue"
y="20">P</text>
+ </svg>
+ </configure>
+ </property>
+ <property name="_editorFactory"
class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
+ </property>
+ <property name="_location" class="ptolemy.kernel.util.Location"
value="[530.0, 40.0]">
+ </property>
+ </property>

It looks like the primary changes are that in the newer version:
_icon is a ValueIcon not an simple Attribute
_editorFactory is a VisibleParameterEditorFactory, not a simple Attribute

2006-05-11 17:53 cxh

  • [r42388]
    /trunk/ptolemy/domains/ct/demo/Pendulum3D/Pendulum3D.xml:
    Adjusted sizes, fixed white box problem with parameters

The diffs are like:

@ -25,7 +25,7 @
<property name="phi" class="ptolemy.data.expr.Parameter" value="PI/6">
<property name="_hideName"
class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute"
value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>
@ -36,7 +36,7 @
</svg>
</configure>
</property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
+ <property name="_editorFactory"
class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
</property>
<property name="_location" class="ptolemy.kernel.util.Location"
value="[200.0, 65.0]">
</property>
@ -44,7 +44,7 @
<property name="theta" class="ptolemy.data.expr.Parameter" value="PI/10">
<property name="_hideName"
class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute"
value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>
@ -55,7 +55,7 @
</svg>
</configure>
</property>
- <property name="_editorFactory" class="ptolemy.kernel.util.Attribute">
+ <property name="_editorFactory"
class="ptolemy.vergil.toolbox.VisibleParameterEditorFactory">
</property>
<property name="_location" class="ptolemy.kernel.util.Location"
value="[200.0, 40.0]">
</property>
@ -63,7 +63,7 @
<property name="phiDot" class="ptolemy.data.expr.Parameter" value="1.0">
<property name="_hideName"
class="ptolemy.kernel.util.SingletonAttribute">
</property>
- <property name="_icon" class="ptolemy.kernel.util.Attribute">
+ <property name="_icon" class="ptolemy.vergil.icon.ValueIcon">
<property name="_color" class="ptolemy.actor.gui.ColorAttribute"
value="{0.0, 0.0, 1.0, 1.0}">
</property>
</property>

#4 Updated by jianwu jianwu over 6 years ago

Hi Sean,

Any updates on this bug and bug 5266?

#5 Updated by Sean Riddle over 6 years ago

Conceptually, one possible fix is already available, as I have documented in the comments to bug 5266. It would involve processing each damaged model, though, to add the missing _icon attribute. An alternate approach would be to add a MoMLFilter to that effect.

Unfortunately, I'm very busy right now with preparations for my qualifying exam. It might be best to reassign these bugs.

(In reply to comment #4)

Hi Sean,

Any updates on this bug and bug 5266?

#6 Updated by Daniel Crawl over 6 years ago

I created a workflow with different types of attributes and uploaded the run to the repository using Kepler 2.3. I was able to import the run and open it using the trunk wrm.

The icon for MonitorReceiverContents had the title since the _icon class is ValueIcon in Kepler 2.3. We could write a MoML filter to convert this to XMLIcon, but it's probably not worth the effort since MonitorReceiverContents is rarely used.

All the other icons displayed correctly.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5598

Also available in: Atom PDF