Project

General

Profile

Bug #4481

KNB authentication and pulling data

Added by shirley shirley almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
data access
Target version:
Start date:
10/20/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4481

Description

In order to sign into KNB with my username and password, I need to clean my cache (no way to manual force the authentication window to pop up). Once I sign into KNB through the "Authenticating for: KNB" window (I enter my username, password, and Organization is NCEAS), I am unable to pull data from KNB (specifically: Kruger National Park ecological aerial census (1998-2007)). I get error messages stating:
Warning
There has been a problem accessing the remote data:
java.rmi.Remote Exception: User public does not have permission to read the document with the docid judithk.707.1

There has been a problem accessing the remote data:
java.rmi.Remote Exception: User public does not have permission to read the document with the docid judithk.819.1

There has been a problem accessing the remote data:
java.rmi.Remote Exception: User public does not have permission to read the document with the docid judithk.951.1

Data entity/entities:2006distance.txt, 2007distance.txt, 2008distance.txt failed to be downloaded, please check the data link in metadata:Download error in .Unnamed1.Kruger National Park ecological aerial survey data (1998-2007)

I have checked the box for Authenticated sources and am registered as logged in to KNB with my own username but am still regarded as User public and cannot pull the data.

History

#1 Updated by Oliver Soong almost 10 years ago

Shirley, just FYI, the authentication window only pops up when needed. That means the first time you do an authenticated search or the first time you access a dataset that requires authentication. If you've already cached that dataset, though, you won't be asked to authenticate but the data will be available. The dataset behavior is by design, although it does sometimes feel a little weird.

On the authentication problem, I can replicate this. It seems that the unauthenticated query (at least sometimes) gets priority over the authenticated query when both are selected as sources.

Shirley, as a workaround, when you want to use that dataset, only select the authenticated query interface in the sources window. It should then work as you expect. You can change back to the unauthenticated query as you need to.

A more ideal solution might be to separate the search results by source. This will eliminate ambiguity in terms of KNB vs. DEV as well as unauthenticated vs. authenticated, and so forth.

#2 Updated by shirley shirley almost 10 years ago

I've tried only searching through the authenticated interface sources, but when I do this, I don't receive any results at all. Only when I add the KNB public search to my sources, do I even get any results. I'm definitely stumped because I am logged in.

#3 Updated by Oliver Soong almost 10 years ago

What are your search terms? There's a surprise about case. Searching for kruger and Kruger are the same for unauthenticated searches, but not for authenticated ones. I use Kruger for authenticated searches.

#4 Updated by shirley shirley almost 10 years ago

hmm I see. I was not capitalizing Kruger. I'm able to see results using only authenticated interface but now I'm getting the same error messages but only applied to me as the user

#5 Updated by Oliver Soong almost 10 years ago

That, uh, would be because you apparently aren't in the kruger-tpc group that has access... Regetz?

#6 Updated by Jim Regetz almost 10 years ago

(In reply to comment #5)

That, uh, would be because you apparently aren't in the kruger-tpc group that
has access... Regetz?

Yes, this was the case, and it has been corrected. The stated workaround should actually work now for Shirley. This just leaves the main bug involving mixed authenticated and unauthenticated querying.

#7 Updated by ben leinfelder almost 10 years ago

What do you think it should look like when you end up searching what are essentially the same sources? Right now the results are merged and duplicates are not shown. I think it would be confusing to see two rows for each EML dataset (1 for authenticated and 1 for regular) but that seems to be the only conclusion that would make sense.
Otherwise we could give preference to the authenticated datasource so that when duplicates are returned we use the authenticated source instead of the regular one.
I believe that the authenticated search will always be a superset of the regular search results.

#8 Updated by ben leinfelder almost 10 years ago

i've added the endpoint to the name of the EML datasource so that they both show in the result set if you have both sources checked

ie:
Kruger National Park megaherbivore census 1985-1990
Kruger National Park megaherbivore census 1985-1990 (AuthenticatedQueryService)

#9 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4481

Also available in: Atom PDF